diff options
author | Eric Blake <eblake@redhat.com> | 2011-05-04 08:18:06 -0600 |
---|---|---|
committer | Eric Blake <eblake@redhat.com> | 2011-05-09 11:51:05 -0600 |
commit | 9d8e01a1db60154cd20abd9f346f99e25576f321 (patch) | |
tree | 0120e2693b17db229a5fb399fa36d268b776e0a4 /bootstrap | |
parent | Remove bogus assert() from migration code (diff) | |
download | libvirt-9d8e01a1db60154cd20abd9f346f99e25576f321.tar.gz libvirt-9d8e01a1db60154cd20abd9f346f99e25576f321.tar.bz2 libvirt-9d8e01a1db60154cd20abd9f346f99e25576f321.zip |
build: translate generated strings
Make sure that xgettext scans generated files for translatable
strings, rather than just files stored in libvirt.git.
* .gnulib: Update, for bootstrap and syntax-check fixes.
* bootstrap: Resynchronize with gnulib.
* cfg.mk (generated_files): Define.
* po/POTFILES.in: Add more files with _().
Diffstat (limited to 'bootstrap')
-rwxr-xr-x | bootstrap | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -1,6 +1,6 @@ #! /bin/sh # Print a version string. -scriptversion=2011-04-05.18; # UTC +scriptversion=2011-05-03.08; # UTC # Bootstrap this package from checked-out sources. @@ -421,7 +421,10 @@ check_versions() { # Honor $APP variables ($TAR, $AUTOCONF, etc.) appvar=`echo $app | tr '[a-z]-' '[A-Z]_'` test "$appvar" = TAR && appvar=AMTAR - eval "app=\${$appvar-$app}" + case $appvar in + GZIP) ;; # Do not use $GZIP: it contains gzip options. + *) eval "app=\${$appvar-$app}" ;; + esac inst_ver=$(get_version $app) if [ ! "$inst_ver" ]; then echo "$me: Error: '$app' not found" >&2 |