aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Fehlig <jfehlig@suse.com>2011-11-15 15:11:49 -0700
committerJim Fehlig <jfehlig@suse.com>2011-11-15 15:11:49 -0700
commit0f590c62b2af15247cafc2cc53815a7edbf5532e (patch)
tree31120307338c7481bf3d229e4e6b6971b3fa2fda /daemon/Makefile.am
parentFix strchr call triggering gcc 4.3 & 4.4 bug (diff)
downloadlibvirt-0f590c62b2af15247cafc2cc53815a7edbf5532e.tar.gz
libvirt-0f590c62b2af15247cafc2cc53815a7edbf5532e.tar.bz2
libvirt-0f590c62b2af15247cafc2cc53815a7edbf5532e.zip
Fix build with polkit0
I missed adding libvirt_driver_remote.la to libvirtd_LDADD in commit b8adfcc6, which didn't cause a problem in 0.9.6 but results in this build error in 0.9.7 libvirtd-remote.o: In function `remoteDispatchAuthPolkit': remote.c:(.text+0x188dd): undefined reference to `virNetServerGetDBusConn'
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index e8c47ae8f..59db217d6 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -156,6 +156,10 @@ endif
if WITH_NWFILTER
libvirtd_LDADD += ../src/libvirt_driver_nwfilter.la
endif
+
+if HAVE_POLKIT0
+ libvirtd_LDADD += ../src/libvirt_driver_remote.la
+endif
endif
libvirtd_LDADD += ../src/libvirt.la