aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Fehlig <jfehlig@novell.com>2011-02-10 15:42:34 -0700
committerJim Fehlig <jfehlig@novell.com>2011-03-18 08:57:48 -0600
commit2b84e445d598894c711278afacfbb9247333bdd8 (patch)
treefc1a018e51d51e3c6bcc6dedcf478c24b6823892 /daemon/Makefile.am
parentutil: Forbid calling hash APIs from iterator callback (diff)
downloadlibvirt-2b84e445d598894c711278afacfbb9247333bdd8.tar.gz
libvirt-2b84e445d598894c711278afacfbb9247333bdd8.tar.bz2
libvirt-2b84e445d598894c711278afacfbb9247333bdd8.zip
Add libxenlight driver
Add a new xen driver based on libxenlight [1], which is the primary toolstack starting with Xen 4.1.0. The driver is stateful and runs privileged only. Like the existing xen-unified driver, the libxenlight driver is accessed with xen:// URI. Driver selection is based on the status of xend. If xend is running, the libxenlight driver will not load and xen:// connections are handled by xen-unified. If xend is not running *and* the libxenlight driver is available, xen:// connections are deferred to the libxenlight driver. V6: - Address several code style issues noted by Daniel Veillard - Make drive work with xen:/// URI - Hold domain object reference while domain is injected in libvirt event loop. Race found and fixed by Markus Groß. V5: - Ensure events are unregistered when domain private data is destroyed. Discovered and fixed by Markus Groß. V4: - Handle restart of libvirtd, reconnecting to previously started domains - Rebased to current master - Tested against Xen 4.1 RC7-pre (c/s 22961:c5d121fd35c0) V3: - Reserve vnc port within driver when autoport=yes V2: - Update to Xen 4.1 RC6-pre (c/s 22940:5a4710640f81) - Rebased to current master - Plug memory leaks found by Stefano Stabellini and valgrind - Handle SHUTDOWN_crash domain death event [1] http://lists.xensource.com/archives/html/xen-devel/2009-11/msg00436.html
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 15e8129bf..9e3a5574f 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -106,6 +106,10 @@ if WITH_LXC
libvirtd_LDADD += ../src/libvirt_driver_lxc.la
endif
+if WITH_LIBXL
+ libvirtd_LDADD += ../src/libvirt_driver_libxl.la
+endif
+
if WITH_UML
libvirtd_LDADD += ../src/libvirt_driver_uml.la
endif