aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Congyang <wency@cn.fujitsu.com>2011-05-13 16:02:50 +0800
committerWen Congyang <wency@cn.fujitsu.com>2011-05-14 13:46:00 +0800
commita1b962ada9b11395a8d507a193db7a20e39ae2ec (patch)
tree157a55c1bf18d7ecc8e639b555b43c6003aa0323 /daemon/Makefile.am
parentcommand: Fix compilation on FreeBSD (diff)
downloadlibvirt-a1b962ada9b11395a8d507a193db7a20e39ae2ec.tar.gz
libvirt-a1b962ada9b11395a8d507a193db7a20e39ae2ec.tar.bz2
libvirt-a1b962ada9b11395a8d507a193db7a20e39ae2ec.zip
build: probes.d and libvirtd.stp should be part of tarball
Steps to reproduce this problem: 1. # ./autogen.sh --without-libvirtd 2. # make dist 3. # rpmbuild --nodeps --define "_sourcedir `pwd`" -ba libvirt.spec ... make[2]: Entering directory `/home/wency/rpmbuild/BUILD/libvirt-0.9.1/daemon' make[2]: *** No rule to make target `probes.d', needed by `probes.h'. Stop. make[2]: Leaving directory `/home/wency/rpmbuild/BUILD/libvirt-0.9.1/daemon' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory `/home/wency/rpmbuild/BUILD/libvirt-0.9.1' make: *** [all] Error 2 error: Bad exit status from /var/tmp/rpm-tmp.WkAD7a (%build)
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 2095c1c23..722957659 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -165,8 +165,6 @@ libvirtd_CFLAGS += $(AVAHI_CFLAGS)
libvirtd_LDADD += $(AVAHI_LIBS)
endif
-EXTRA_DIST += probes.d libvirtd.stp
-
if WITH_DTRACE
libvirtd_LDADD += probes.o
nodist_libvirtd_SOURCES = probes.h
@@ -349,6 +347,8 @@ uninstall-local:: uninstall-data-sasl
endif # WITH_LIBVIRTD
# This is needed for 'make dist' too, so can't wrap in WITH_LIBVIRTD.
+EXTRA_DIST += probes.d libvirtd.stp
+
POD2MAN = pod2man -c "Virtualization Support" \
-r "$(PACKAGE)-$(VERSION)" -s 8