aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2010-12-10 12:27:33 +0000
committerDaniel P. Berrange <berrange@redhat.com>2011-06-24 11:48:49 +0100
commitb17b4afafd418cd809dc061581a0d07755cceff1 (patch)
tree2befe54559e15b5c0acf9c610b20457bf8d0f447 /daemon/Makefile.am
parentIntroduce generic RPC client objects (diff)
downloadlibvirt-b17b4afafd418cd809dc061581a0d07755cceff1.tar.gz
libvirt-b17b4afafd418cd809dc061581a0d07755cceff1.tar.bz2
libvirt-b17b4afafd418cd809dc061581a0d07755cceff1.zip
Move the RPC generator scripts into src/rpc
Move the daemon/remote_generator.pl to src/rpc/gendispatch.pl and move the src/remote/rpcgen_fix.pl to src/rpc/genprotocol.pl * daemon/Makefile.am: Update for new name/location of generator * src/Makefile.am: Update for new name/location of generator
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am41
1 files changed, 20 insertions, 21 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index c1b4a9fb9..ad14c901e 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -28,7 +28,6 @@ AVAHI_SOURCES = \
DISTCLEANFILES =
EXTRA_DIST = \
- remote_generator.pl \
remote_dispatch_bodies.h \
qemu_dispatch_bodies.h \
libvirtd.conf \
@@ -56,54 +55,54 @@ BUILT_SOURCES =
REMOTE_PROTOCOL = $(top_srcdir)/src/remote/remote_protocol.x
QEMU_PROTOCOL = $(top_srcdir)/src/remote/qemu_protocol.x
-$(srcdir)/remote_dispatch_prototypes.h: $(srcdir)/remote_generator.pl \
+$(srcdir)/remote_dispatch_prototypes.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(REMOTE_PROTOCOL)
- $(AM_V_GEN)perl -w $(srcdir)/remote_generator.pl -c -p remote \
+ $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -c -p remote \
$(REMOTE_PROTOCOL) > $@
-$(srcdir)/remote_dispatch_table.h: $(srcdir)/remote_generator.pl \
+$(srcdir)/remote_dispatch_table.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(REMOTE_PROTOCOL)
- $(AM_V_GEN)perl -w $(srcdir)/remote_generator.pl -c -t remote \
+ $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -c -t remote \
$(REMOTE_PROTOCOL) > $@
-$(srcdir)/remote_dispatch_args.h: $(srcdir)/remote_generator.pl \
+$(srcdir)/remote_dispatch_args.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(REMOTE_PROTOCOL)
- $(AM_V_GEN)perl -w $(srcdir)/remote_generator.pl -c -a remote \
+ $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -c -a remote \
$(REMOTE_PROTOCOL) > $@
-$(srcdir)/remote_dispatch_ret.h: $(srcdir)/remote_generator.pl \
+$(srcdir)/remote_dispatch_ret.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(REMOTE_PROTOCOL)
- $(AM_V_GEN)perl -w $(srcdir)/remote_generator.pl -c -r remote \
+ $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -c -r remote \
$(REMOTE_PROTOCOL) > $@
-$(srcdir)/remote_dispatch_bodies.h: $(srcdir)/remote_generator.pl \
+$(srcdir)/remote_dispatch_bodies.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(REMOTE_PROTOCOL)
- $(AM_V_GEN)perl -w $(srcdir)/remote_generator.pl -c -b remote \
+ $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -c -b remote \
$(REMOTE_PROTOCOL) > $@
-$(srcdir)/qemu_dispatch_prototypes.h: $(srcdir)/remote_generator.pl \
+$(srcdir)/qemu_dispatch_prototypes.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(QEMU_PROTOCOL)
- $(AM_V_GEN)perl -w $(srcdir)/remote_generator.pl -p qemu \
+ $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -p qemu \
$(QEMU_PROTOCOL) > $@
-$(srcdir)/qemu_dispatch_table.h: $(srcdir)/remote_generator.pl \
+$(srcdir)/qemu_dispatch_table.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(QEMU_PROTOCOL)
- $(AM_V_GEN)perl -w $(srcdir)/remote_generator.pl -t qemu \
+ $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -t qemu \
$(QEMU_PROTOCOL) > $@
-$(srcdir)/qemu_dispatch_args.h: $(srcdir)/remote_generator.pl \
+$(srcdir)/qemu_dispatch_args.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(QEMU_PROTOCOL)
- $(AM_V_GEN)perl -w $(srcdir)/remote_generator.pl -a qemu \
+ $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -a qemu \
$(QEMU_PROTOCOL) > $@
-$(srcdir)/qemu_dispatch_ret.h: $(srcdir)/remote_generator.pl \
+$(srcdir)/qemu_dispatch_ret.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(QEMU_PROTOCOL)
- $(AM_V_GEN)perl -w $(srcdir)/remote_generator.pl -r qemu \
+ $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -r qemu \
$(QEMU_PROTOCOL) > $@
-$(srcdir)/qemu_dispatch_bodies.h: $(srcdir)/remote_generator.pl \
+$(srcdir)/qemu_dispatch_bodies.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(QEMU_PROTOCOL)
- $(AM_V_GEN)perl -w $(srcdir)/remote_generator.pl -b qemu \
+ $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -b qemu \
$(QEMU_PROTOCOL) > $@
if WITH_LIBVIRTD