aboutsummaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-09-05 11:55:42 -0600
committerEric Blake <eblake@redhat.com>2012-09-05 12:05:55 -0600
commitd51024aee6ddfe0934b600e4fae84d00a2f5ab2f (patch)
tree7cb8bd33c79ed48dbdc8f7c84a1085875265dd8f /docs
parentbuild: avoid warnings from gcc 4.2.1 (diff)
downloadlibvirt-d51024aee6ddfe0934b600e4fae84d00a2f5ab2f.tar.gz
libvirt-d51024aee6ddfe0934b600e4fae84d00a2f5ab2f.tar.bz2
libvirt-d51024aee6ddfe0934b600e4fae84d00a2f5ab2f.zip
build: don't fail when xsltproc is missing
On a machine without xsltproc, the build failed with: Scripting search.php /usr/local/bin/bash: line 1: search.php.tmp: No such file or directory rm: ./search.php: No such file or directory Regression introduced in commit 28183590. * docs/Makefile.am (%.php): Skip in the same conditions when the .tmp file is skipped.
Diffstat (limited to 'docs')
-rw-r--r--docs/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index fad8979ba..91c3d33e2 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -186,10 +186,11 @@ internals/%.html.tmp: internals/%.html.in subsite.xsl page.xsl sitemap.html.in
|| { rm $@ && exit 1; }; fi
%.php: %.php.tmp %.php.code.in
- @echo "Scripting $@"; \
- sed -e '/<a id="php_placeholder"><\/a>/r '"$(srcdir)/$@.code.in" \
- -e /php_placeholder/d < $@.tmp > $(srcdir)/$@ \
- || { rm $(srcdir)/$@ && exit 1; }
+ @if [ -x $(XSLTPROC) ] ; then \
+ echo "Scripting $@"; \
+ sed -e '/<a id="php_placeholder"><\/a>/r '"$(srcdir)/$@.code.in" \
+ -e /php_placeholder/d < $@.tmp > $(srcdir)/$@ \
+ || { rm $(srcdir)/$@ && exit 1; }; fi
html/index.html: libvirt-api.xml newapi.xsl page.xsl sitemap.html.in
$(AM_V_GEN)if [ -x $(XSLTPROC) ] ; then \