summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/contextl/contextl-0.51.ebuild')
-rw-r--r--dev-lisp/contextl/contextl-0.51.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-lisp/contextl/contextl-0.51.ebuild b/dev-lisp/contextl/contextl-0.51.ebuild
new file mode 100644
index 00000000..0e53a40d
--- /dev/null
+++ b/dev-lisp/contextl/contextl-0.51.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit common-lisp-2
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="CLOS extension for context-oriented Programming"
+HOMEPAGE="http://common-lisp.net/project/closer/"
+SRC_URI="http://common-lisp.net/project/closer/ftp/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="!dev-lisp/cl-${PN}
+ dev-lisp/lw-compat
+ dev-lisp/closer-mop
+ dev-lisp/portable-threads"
+
+S="${WORKDIR}"/${MY_P}
+
+src_install() {
+ common-lisp-install *.{lisp,asd} test/*.lisp
+ common-lisp-symlink-asdf
+}