aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAvi Kivity <avi@redhat.com>2009-12-07 10:57:57 +0200
committerAvi Kivity <avi@redhat.com>2009-12-07 10:57:57 +0200
commit733bd8964598df596b362ee529200ea3694b1b3a (patch)
treecd562dae077e59a5290432c210ea6925bde4c9d6 /Makefile
parentMerge commit '5fa737a4792c0aef9cf0588242336eefb0cb8ca8' into upstream-merge (diff)
parentIntroduce rerror option for drives (diff)
downloadqemu-kvm-733bd8964598df596b362ee529200ea3694b1b3a.tar.gz
qemu-kvm-733bd8964598df596b362ee529200ea3694b1b3a.tar.bz2
qemu-kvm-733bd8964598df596b362ee529200ea3694b1b3a.zip
Merge commit 'e9b2e81889d9877415710484b876ee57a42b0bcb' into upstream-merge
* commit 'e9b2e81889d9877415710484b876ee57a42b0bcb': (140 commits) Introduce rerror option for drives Rename DriveInfo.onerror to on_write_error ram migration: Properly reset statistics qemu-opts: Release id on deletion live migration: Serialize vmstate saving in stage 2 block migration: Skip zero-sized disks block migration: Increase dirty chunk size to 1M block migration: Add support for restore progress reporting block migration: Report progress also via info migration block migration: Fix outgoing progress output live migration: Propagate output monitor to callback handler block migration: Report overall migration progress live migration: Allow cleanup after cancellation or error ram migration: Stop loading on error block migration: Add error handling/propagation block migration: Consolidate block transmission block migration: Consolidate mig_read_device_bulk into mig_save_device_bulk block migration: Clean up use of total_sectors block migration: Initialize remaining BlkMigState fields block migration: Switch device and block lists to QSIMPLEQ ... Conflicts: vl.c Signed-off-by: Avi Kivity <avi@redhat.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 4829ab7c1..75c7fc5d4 100644
--- a/Makefile
+++ b/Makefile
@@ -112,13 +112,17 @@ block-nested-$(CONFIG_CURL) += curl.o
block-obj-y += $(addprefix block/, $(block-nested-y))
net-obj-y = net.o
-net-nested-y = queue.o checksum.o
+net-nested-y = queue.o checksum.o util.o
+net-nested-y += socket.o
+net-nested-y += dump.o
net-nested-$(CONFIG_POSIX) += tap.o
net-nested-$(CONFIG_LINUX) += tap-linux.o
net-nested-$(CONFIG_WIN32) += tap-win32.o
net-nested-$(CONFIG_BSD) += tap-bsd.o
net-nested-$(CONFIG_SOLARIS) += tap-solaris.o
net-nested-$(CONFIG_AIX) += tap-aix.o
+net-nested-$(CONFIG_SLIRP) += slirp.o
+net-nested-$(CONFIG_VDE) += vde.o
net-obj-y += $(addprefix net/, $(net-nested-y))
######################################################################