aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Tosatti <mtosatti@redhat.com>2009-10-14 17:40:46 -0300
committerMarcelo Tosatti <mtosatti@redhat.com>2009-10-14 17:40:46 -0300
commitb08e9748ff26914b5a29032923e03f2670822de8 (patch)
tree869dfb199647436d40ec8b616acb5cfc2da4a7a6 /pc-bios
parentMerge commit '0f457d91c41047f0f22c2e6965fbd154c5cd07d9' into upstream-merge (diff)
parentMove generation of config-host.h to Makefile from configure (diff)
downloadqemu-kvm-b08e9748ff26914b5a29032923e03f2670822de8.tar.gz
qemu-kvm-b08e9748ff26914b5a29032923e03f2670822de8.tar.bz2
qemu-kvm-b08e9748ff26914b5a29032923e03f2670822de8.zip
Merge commit '1215c6e7615897e4a0bfd6867b762a47fc34f37f' into upstream-merge
* commit '1215c6e7615897e4a0bfd6867b762a47fc34f37f': Move generation of config-host.h to Makefile from configure Don't include config-host.mak from inside config.mak CRIS: Update PR_EDA on TLB faults. Clean up test for qdev_init() failure Warn if value of qdev_init() isn't checked Make isa_create() terminate program on failure New qdev_init_nofail() Check return value of qdev_init() Make qdev_init() destroy the device on failure Unbreak USB autoconnect filters tcg: improve output log target-i386: fix ARPL configure and Makefile are not generated in qemu Don't use implicit rules for Makefile optionrom: create .PHONY variable add build-all to .PHONY rules optionrom: remove use of implicit RM variable AIOLIBS is not used anywhere qdev: move comment Conflicts: Makefile Signed-off-by: Marcelo Tosatti <mtosatti@redhat.com>
Diffstat (limited to 'pc-bios')
-rw-r--r--pc-bios/optionrom/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/pc-bios/optionrom/Makefile b/pc-bios/optionrom/Makefile
index 3b25e3101..73e74d839 100644
--- a/pc-bios/optionrom/Makefile
+++ b/pc-bios/optionrom/Makefile
@@ -6,6 +6,7 @@ include ../../config-host.mak
include $(SRC_PATH)/rules.mak
VPATH=$(SRC_PATH)/pc-bios/optionrom
+.PHONY : all clean build-all
CFLAGS := -Wall -Wstrict-prototypes -Werror -fomit-frame-pointer -fno-builtin
CFLAGS += -I$(SRC_PATH)
@@ -24,4 +25,4 @@ build-all: multiboot.bin extboot.bin
$(call quiet-command,$(SHELL) $(SRC_PATH)/pc-bios/optionrom/signrom.sh $< $@," Signing $(TARGET_DIR)$@")
clean:
- $(RM) *.o *.d *.raw *.img *.bin *~
+ rm -f *.o *.d *.raw *.img *.bin *~