aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Mitrak <lucas@lucasmitrak.com>2021-09-19 02:10:09 -0400
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-20 10:52:33 +0200
commit748646f321601c12ab799437b9774e158fd902b8 (patch)
tree9ef63edc19ff594d53bce22200a80b15aed3ae77 /sci-mathematics
parentsci-mathematics/acl2: Require >=dev-lisp/sbcl-1.5.2 in BDEPEND (diff)
downloadsci-748646f321601c12ab799437b9774e158fd902b8.tar.gz
sci-748646f321601c12ab799437b9774e158fd902b8.tar.bz2
sci-748646f321601c12ab799437b9774e158fd902b8.zip
sci-mathematics/acl2: Update 8.3 to the original intended ebuild
* Update 8.3's ebuild to the one originally intended for 8.3 Currently, sci-mathematics/acl2-8.3 will not compile to the fixed bug 755368 [1]. This bug was fixed in PR 1109 on github [2]. However, due to a version bump, acl2-8.3 remains unchanged. Therefore the ebuild for 8.3 should be updated to the original PR. acl2-8.3 was tested to work with the latest unstable version of sbcl-2.1.8. With this commit, acl2-8.3 will install successfully. Without this commit, it will not. [1] https://bugs.gentoo.org/755368 [2] https://github.com/gentoo/sci/pull/1109 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Lucas Mitrak <lucas@lucasmitrak.com> Closes: https://github.com/gentoo/sci/pull/1114 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/acl2/acl2-8.3-r1.ebuild86
-rw-r--r--sci-mathematics/acl2/acl2-8.3.ebuild51
2 files changed, 86 insertions, 51 deletions
diff --git a/sci-mathematics/acl2/acl2-8.3-r1.ebuild b/sci-mathematics/acl2/acl2-8.3-r1.ebuild
new file mode 100644
index 000000000..d0bb4eade
--- /dev/null
+++ b/sci-mathematics/acl2/acl2-8.3-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="Industrial strength theorem prover"
+HOMEPAGE="https://www.cs.utexas.edu/users/moore/acl2/"
+SRC_URI="https://github.com/acl2/acl2/archive/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="books doc emacs"
+
+BDEPEND="
+ dev-lisp/sbcl
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+DEPEND="
+ dev-lisp/sbcl:=
+ books? ( dev-lang/perl )
+ doc? ( dev-lang/perl )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-use_make_variable.patch )
+
+src_prepare() {
+ find . -type f -name "*.bak" -delete
+ find . -type f -name "*.orig" -delete
+ # Remove sparc binary inadvertently included in upstream
+ rm books/workshops/2003/schmaltz-al-sammane-et-al/support/acl2link || die
+ default
+}
+
+src_compile() {
+ emake LISP="sbcl --noinform --noprint \
+ --no-sysinit --no-userinit --disable-debugger"
+
+ if use books; then
+ emake "ACL2=${S}/saved_acl2" basic
+ fi
+
+ if use doc; then
+ emake "ACL2=${S}/saved_acl2" DOC
+ fi
+
+ if use emacs; then
+ elisp-compile emacs/*.el
+ fi
+}
+
+src_install() {
+ local SAVED_NAME=saved_acl2
+ sed -e "s:${S}:/usr/share/acl2:g" -i ${SAVED_NAME} || die
+ dobin ${SAVED_NAME}
+
+ insinto /usr/share/acl2
+ doins ${SAVED_NAME}.core
+ if use books; then
+ sed -e "/5/a export ACL2_SYSTEM_BOOKS=/usr/share/acl2/books/" \
+ -i ${SAVED_NAME} || die
+ doins -r books
+ fi
+
+ DOCS=( books/README.md )
+ if use doc; then
+ HTML_DOCS=( doc/HTML/. )
+ fi
+ einstalldocs
+
+ if use emacs; then
+ elisp-install ${PN} emacs/*{.el,elc}
+ doins TAGS
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/acl2/acl2-8.3.ebuild b/sci-mathematics/acl2/acl2-8.3.ebuild
deleted file mode 100644
index 63326e257..000000000
--- a/sci-mathematics/acl2/acl2-8.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit eutils
-
-DESCRIPTION="Industrial strength theorem prover"
-HOMEPAGE="https://www.cs.utexas.edu/users/moore/acl2/"
-MY_PN=${PN}-devel
-SRC_URI="https://github.com/${MY_PN}/${MY_PN}/releases/download/${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="books"
-
-BDEPEND="dev-lisp/sbcl"
-DEPEND="
- dev-lisp/sbcl:=
- books? ( dev-lang/perl )
-"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- emake LISP="sbcl --noinform --noprint \
- --no-sysinit --no-userinit --disable-debugger"
-
- if use books; then
- echo
- einfo "Building certificates ..."
- einfo "(this may take hours to finish)"
- emake certify-books
- fi
-}
-
-src_install() {
- SAVED_NAME=saved_acl2
- sed -e "s:${S}:/usr/share/acl2:g" -i ${SAVED_NAME} || die
- if use books; then
- sed -e "/5/a export ACL2_SYSTEM_BOOKS=/usr/share/acl2/books/" \
- -i ${SAVED_NAME} || die
- fi
- dobin ${SAVED_NAME}
-
- insinto /usr/share/acl2
- doins TAGS ${SAVED_NAME}.core
- if use books; then
- doins -r books
- fi
-}