aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Zaytsev <alexey.zaytsev@gmail.com>2008-12-17 22:01:18 +0300
committerAlexey Zaytsev <alexey.zaytsev@gmail.com>2008-12-18 20:30:22 +0300
commit1839db92cd1b7c1374982ae90e6f5dd1b151d887 (patch)
tree4697e65d286e7cd4ce478b1fa0b7b00aa9c16d3a /Makefile
parentHandle missing argument to -D. (diff)
downloadsparse-1839db92cd1b7c1374982ae90e6f5dd1b151d887.tar.gz
sparse-1839db92cd1b7c1374982ae90e6f5dd1b151d887.tar.bz2
sparse-1839db92cd1b7c1374982ae90e6f5dd1b151d887.zip
Gdb macros to get a better look at some sparse data structures.
Note that we need to build sparse with -g3 -gdwarf-2 to get the cpp macros included into the debug ingo. Signed-off-by: Alexey Zaytsev <alexey.zaytsev@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 3eab17e..ca33218 100644
--- a/Makefile
+++ b/Makefile
@@ -1,19 +1,21 @@
VERSION=0.4.1
-OS ?= linux
+OS = linux
-CC ?= gcc
-CFLAGS ?= -O2 -finline-functions -fno-strict-aliasing -g
-CFLAGS += -Wall -Wwrite-strings
-LDFLAGS ?= -g
-AR ?= ar
-HAVE_LIBXML=$(shell pkg-config --exists libxml-2.0 && echo 'yes')
+CC = gcc
+CFLAGS = -O2 -finline-functions -fno-strict-aliasing -g
+CFLAGS += -Wall -Wwrite-strings
+LDFLAGS += -g
+AR = ar
#
# For debugging, uncomment the next one
#
-CFLAGS += -DDEBUG
+#CFLAGS += -O0 -DDEBUG -g3 -gdwarf-2
+
+HAVE_LIBXML=$(shell pkg-config --exists libxml-2.0 && echo 'yes')
+
DESTDIR=
PREFIX=$(HOME)
@@ -191,7 +193,7 @@ pre-process.h:
$(QUIET_CC)$(CC) -o $@ -c $(CFLAGS) $<
clean: clean-check
- rm -f *.[oa] $(PROGRAMS) $(SLIB_FILE) pre-process.h sparse.pc
+ rm -f *.[oa] *.so $(PROGRAMS) $(SLIB_FILE) pre-process.h sparse.pc
dist:
@if test "`git describe`" != "$(VERSION)" ; then \