diff options
author | Josh Triplett <josh@freedesktop.org> | 2007-07-22 20:27:57 -0700 |
---|---|---|
committer | Josh Triplett <josh@freedesktop.org> | 2007-07-22 20:27:57 -0700 |
commit | 33683d9fd2b3d6d240c539e50e61af0fca0fe5aa (patch) | |
tree | 6f8a3daae8586ba1976c461cdd2d524d1ec89e35 /Makefile | |
parent | Fix sparse warnings in c2xml: mark globals static and remove unused globals (diff) | |
download | sparse-33683d9fd2b3d6d240c539e50e61af0fca0fe5aa.tar.gz sparse-33683d9fd2b3d6d240c539e50e61af0fca0fe5aa.tar.bz2 sparse-33683d9fd2b3d6d240c539e50e61af0fca0fe5aa.zip |
Fix test-suite to handle stdout and stderr separately, and fix up tests
test-suite merged stdout and stderr, which relied on the ordering of data from
the two streams in the merged stream. This made test-suite frequently fail on
tests with both output and errors, when the ordering didn't happen to match
what the test assumed. Handle each of the streams separately, and update the
tests accordingly.
Also clean up the output of "test-suite format" to avoid outputting values
equal to the defaults.
Signed-off-by: Josh Triplett <josh@freedesktop.org>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 9 |
1 files changed, 7 insertions, 2 deletions
@@ -188,5 +188,10 @@ check: all $(Q)cd validation && ./test-suite clean-check: - find validation/ -name "*.c.[egd]*" -exec rm {} \; - + find validation/ \( -name "*.c.output.expected" \ + -o -name "*.c.output.got" \ + -o -name "*.c.output.diff" \ + -o -name "*.c.error.expected" \ + -o -name "*.c.error.got" \ + -o -name "*.c.error.diff" \ + \) -exec rm {} \; |