diff options
author | 2008-12-18 20:22:26 +0300 | |
---|---|---|
committer | 2008-12-18 21:11:00 +0300 | |
commit | 95f9d2d8a576a1abd06c677bc494a9f9b5c105cc (patch) | |
tree | 4e2e1755d26701fa0cf3b87ca6d94d2be59b05d5 /Makefile | |
parent | Expand "dubious !x & y" handling to other combinations of !, &, and |. (diff) | |
download | sparse-95f9d2d8a576a1abd06c677bc494a9f9b5c105cc.tar.gz sparse-95f9d2d8a576a1abd06c677bc494a9f9b5c105cc.tar.bz2 sparse-95f9d2d8a576a1abd06c677bc494a9f9b5c105cc.zip |
Set gcc include path at runtime.
You can now tell sparse where to look for the compiler
headers with -gcc-base-dir <dir>. Otherwise sparse will
look for headers used to build it.
Also adds $GCC_BASE/include-fixed used by newer gcc
versions.
Signed-off-by: Alexey zaytsev <alexey.zaytsev@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 7 |
1 files changed, 3 insertions, 4 deletions
@@ -17,6 +17,8 @@ AR = ar HAVE_LIBXML=$(shell pkg-config --exists libxml-2.0 && echo 'yes') +CFLAGS += -DGCC_BASE=\"$(shell $(CC) --print-file-name=)\" + DESTDIR= PREFIX=$(HOME) BINDIR=$(PREFIX)/bin @@ -147,7 +149,7 @@ lib.o: $(LIB_H) allocate.o: $(LIB_H) ptrlist.o: $(LIB_H) parse.o: $(LIB_H) -pre-process.o: $(LIB_H) pre-process.h +pre-process.o: $(LIB_H) scope.o: $(LIB_H) show-parse.o: $(LIB_H) symbol.o: $(LIB_H) @@ -186,9 +188,6 @@ compat-solaris.o: compat/mmap-blob.c $(LIB_H) compat-mingw.o: $(LIB_H) compat-cygwin.o: $(LIB_H) -pre-process.h: - $(QUIET_GEN)echo "#define GCC_INTERNAL_INCLUDE \"`$(CC) -print-file-name=include`\"" > pre-process.h - .c.o: $(QUIET_CC)$(CC) -o $@ -c $(CFLAGS) $< |