aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Triplett <josht@us.ibm.com>2006-08-29 17:41:46 -0700
committerLinus Torvalds <torvalds@g5.osdl.org>2006-08-29 19:09:31 -0700
commita0db384dbb4bbb605ccef2c4ed06e0850e75907b (patch)
treeb429d537912668fe44b59917a12934d6ae75249d /Makefile
parent[PATCH] Add support for GCC's __builtin_va_copy (diff)
downloadsparse-a0db384dbb4bbb605ccef2c4ed06e0850e75907b.tar.gz
sparse-a0db384dbb4bbb605ccef2c4ed06e0850e75907b.tar.bz2
sparse-a0db384dbb4bbb605ccef2c4ed06e0850e75907b.zip
[PATCH] Use $(BINDIR) consistently in Makefile rather than $(PREFIX)/bin
The Makefile has variables for both PREFIX (default $(HOME)) and BINDIR (default $(PREFIX)/bin); however, it then uses $(PREFIX)/bin in several other places, making it difficult to install to an alternate BINDIR. Fix this by using $(BINDIR) consistently throughout the Makefile. Signed-off-by: Josh Triplett <josh@freedesktop.org> Signed-off-by: Linus Torvalds <torvalds@osdl.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 378ee72..6755e07 100644
--- a/Makefile
+++ b/Makefile
@@ -45,11 +45,11 @@ all: $(PROGRAMS) $(SLIB_FILE)
# "The better to keep you on your toes, my dear".
#
install: check $(SLIB_FILE) bin-dir
- if test $< -nt $(PREFIX)/bin/sparse ; then install -v $< $(BINDIR)/sparse ; install -v $(SLIB_FILE) $(BINDIR) ; fi
+ if test $< -nt $(BINDIR)/sparse ; then install -v $< $(BINDIR)/sparse ; install -v $(SLIB_FILE) $(BINDIR) ; fi
bin-dir:
- @if ! test -d $(PREFIX)/bin; then \
- echo "No '$(PREFIX)/bin' directory to install in"; \
+ @if ! test -d $(BINDIR); then \
+ echo "No '$(BINDIR)' directory to install in"; \
echo "Please create it and add it to your PATH"; \
exit 1; \
fi