diff options
author | Damien Lespiau <damien.lespiau@gmail.com> | 2007-07-02 06:41:34 +0200 |
---|---|---|
committer | Josh Triplett <josh@freedesktop.org> | 2007-07-08 11:46:02 -0700 |
commit | e99ed37cb3ae84cb41f5550997363a196bb47cf2 (patch) | |
tree | 2be54fa7da8cd7b79b9c93baa88c4d4cec0afbe4 /Makefile | |
parent | Move all the preprocessor tests into validation/preprocessor/ (diff) | |
download | sparse-e99ed37cb3ae84cb41f5550997363a196bb47cf2.tar.gz sparse-e99ed37cb3ae84cb41f5550997363a196bb47cf2.tar.bz2 sparse-e99ed37cb3ae84cb41f5550997363a196bb47cf2.zip |
test-suite: a tiny test automation script
This patch introduces test-suite, a simple script that makes test cases
verification easier. Test cases in the validation directory are annotated
and this script parses them to check if the actual result is the one
expected by the test writer.
Signed-off-by: Damien Lespiau <damien.lespiau@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 7 |
1 files changed, 7 insertions, 0 deletions
@@ -168,3 +168,10 @@ dist: exit 1 ; \ fi git archive --format=tar --prefix=sparse-$(VERSION)/ HEAD^{tree} | gzip -9 > sparse-$(VERSION).tar.gz + +check: all + $(Q)cd validation && ./test-suite + +clean-check: + find validation/ -name "*.c.[egd]*" -exec rm {} \; + |