summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mtag/mtag-3.ebuild')
-rw-r--r--media-sound/mtag/mtag-3.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/media-sound/mtag/mtag-3.ebuild b/media-sound/mtag/mtag-3.ebuild
index 5369b56e7..260871a06 100644
--- a/media-sound/mtag/mtag-3.ebuild
+++ b/media-sound/mtag/mtag-3.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit cmake-utils
+EAPI=4
-DESCRIPTION="the fast media tag lib"
+inherit cmake-utils eutils
+
+DESCRIPTION="Fast media tag lib"
HOMEPAGE="http://mtag.berlios.de/"
SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
@@ -14,15 +16,19 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc"
RDEPEND="media-libs/taglib
- >=dev-db/sqlite-3.3.12"
+ dev-db/sqlite:3"
DEPEND="${RDEPEND}"
CMAKE_IN_SOURCE_BUILD=1
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+}
+
src_install() {
- dobin mtag || die "dobin failed"
- dodoc README ChangeLog AUTHORS || die "dodoc failed"
+ dobin ${PN}
+ dodoc AUTHORS ChangeLog README
if use doc; then
- dohtml -r html/* || die "dohtml failed"
+ dohtml -r html/*
fi
}