summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild')
-rw-r--r--sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild b/sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild
index 875ea58e5..a271ef53f 100644
--- a/sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild
+++ b/sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild
@@ -10,7 +10,7 @@ SRC_URI="http://hollowtube.mine.nu/releases/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="sys-libs/pam"
@@ -18,7 +18,8 @@ RDEPEND="${DEPEND}
app-crypt/hashalot"
src_compile() {
- append-flags "-fPIC -c -Wall -Wformat-security"
+ # fix strict aliasing problems, using -fno-strict-aliasing
+ append-flags "-fPIC -c -Wall -Wformat-security -fno-strict-aliasing"
emake CC="$(tc-getCC)" \
LD="$(tc-getLD)" \
CFLAGS="${CFLAGS}" || die "emake failed"
@@ -30,3 +31,8 @@ src_install() {
dodoc README
dosbin hashpass
}
+
+pkg_postinst() {
+ elog "See /usr/share/doc/${PF}/README.bz2 for configuration info"
+ elog ""
+} \ No newline at end of file