summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-21 09:01:52 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-21 09:54:38 +0100
commit69790eff169839bc7b7b49de58cac2dc828efb46 (patch)
treef3786bf438e4a9913c62adec1f454753507d8cff
parentdev-python/slixmpp: Bump to 1.8.1 (diff)
downloadgentoo-69790eff169839bc7b7b49de58cac2dc828efb46.tar.gz
gentoo-69790eff169839bc7b7b49de58cac2dc828efb46.tar.bz2
gentoo-69790eff169839bc7b7b49de58cac2dc828efb46.zip
dev-python/arpeggio: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/arpeggio/Manifest1
-rw-r--r--dev-python/arpeggio/arpeggio-2.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/arpeggio/Manifest b/dev-python/arpeggio/Manifest
index 5018a6b19280..2089f493bee8 100644
--- a/dev-python/arpeggio/Manifest
+++ b/dev-python/arpeggio/Manifest
@@ -1 +1,2 @@
DIST Arpeggio-1.10.2.tar.gz 766747 BLAKE2B 91e828731757b6ca1e16900edca3f45378c5bb05469e1d32571f9185dbb887f5cf6ae54afecf77f352f882d9056a0814c65aabf51424b482ae3a8cb90f11740a SHA512 c6a162f9ab854bac7e2bc9e5d5553c2dbcc068fcf61607149727cd4c8a7c87c63cab765b423c8ea76e09fa81ccc42157d724388a81e22864580ccf734998142a
+DIST Arpeggio-2.0.0.tar.gz 767813 BLAKE2B b4eab5b0a049560e8f3d775f34e9d1beffc26d3969a11a2043d203852c77385adbbef876e212b09c6af8630f2b8de6dfb088760bf9ade332af981d4e8d8267ad SHA512 b5a75eea515b7dd0ad7dc261703300bd5b3e5a70f0946845f8828dbf7c76613aef926fed9538fe0f9a71c1666edc9f8cff31afddd551bea1d7b1b9ad7a9cc405
diff --git a/dev-python/arpeggio/arpeggio-2.0.0.ebuild b/dev-python/arpeggio/arpeggio-2.0.0.ebuild
new file mode 100644
index 000000000000..cbafce6c06dc
--- /dev/null
+++ b/dev-python/arpeggio/arpeggio-2.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parser interpreter based on PEG grammars"
+HOMEPAGE="https://pypi.org/project/Arpeggio/ https://github.com/textX/Arpeggio"
+SRC_URI="
+ https://github.com/textX/Arpeggio/archive/${PV}.tar.gz -> ${P^}.tar.gz
+"
+S=${WORKDIR}/${P^}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/memory_profiler[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/^setup_requires/,/^[^[:space:]]/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}