summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 04:27:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:10 -0400
commitc45e1dcc14f12c9e6718669493ef226800b6270b (patch)
treeb27e456cbe22c3beb35c8caad88e95c7776d8c92
parentnet-misc/vncrec: fix build with clang (diff)
downloadgentoo-c45e1dcc14f12c9e6718669493ef226800b6270b.tar.gz
gentoo-c45e1dcc14f12c9e6718669493ef226800b6270b.tar.bz2
gentoo-c45e1dcc14f12c9e6718669493ef226800b6270b.zip
net-misc/x11-ssh-askpass: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild b/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
index a799f42b4c5e..155003835707 100644
--- a/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
+++ b/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,13 +21,14 @@ RDEPEND="virtual/ssh
x11-libs/libXt"
DEPEND="${RDEPEND}"
BDEPEND="app-text/rman
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1"
src_configure() {
econf --libexecdir=/usr/"$(get_libdir)"/misc \
--disable-installing-app-defaults
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die "xmkmf failed"
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die "xmkmf failed"
}
src_compile() {