summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-07 05:50:15 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-07 06:43:23 +0200
commitfcbb87dcd62069a5189b62bccfe87e0bc4d7d930 (patch)
tree9f9b072bcf440defe82cc2bc2266ae8525b86076
parentapp-admin/bitwarden-desktop-bin: drop 2024.7.1, 2024.8.1 (diff)
downloadgentoo-fcbb87dcd62069a5189b62bccfe87e0bc4d7d930.tar.gz
gentoo-fcbb87dcd62069a5189b62bccfe87e0bc4d7d930.tar.bz2
gentoo-fcbb87dcd62069a5189b62bccfe87e0bc4d7d930.zip
dev-python/networkx: Bump to 3.4_rc0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/networkx/Manifest1
-rw-r--r--dev-python/networkx/networkx-3.4_rc0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index 9bf7a5408402..ad9c884c618e 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1 +1,2 @@
DIST networkx-3.3.tar.gz 2126579 BLAKE2B 37d5d536e2564f9a219df70bb7f1b7c0717b99e9cdb7a4050aa321609a0ef34caecfda5a6ed8cb17f4d3b305b667adf8e40b58568dde8eb942d4a00b1ebdb255 SHA512 86306cabd7e15aa79cae4d84a42e8804b1e904fc2127725067a80e3ddf31f0fa72ebb9d21284018e72bdfc662c766a5be55564572aadaf7392dada7ea93d1ea4
+DIST networkx-3.4rc0.tar.gz 2146054 BLAKE2B 9a183740a97136c85c75c1f34c11a6a753c0b1fc418074bcb02388822ddd2b7f5a53fc8f3866736dfb9833a300cf2e5d0776cbdceefcabdf0470cc89e790948e SHA512 14f19e1e524b8e9dfa55ecab34fcbb426460e29633284ec62957abd143f54685ceae3993306f3beff3a33d3cb7f3e408be417971fde11c75827ef05d999dc5f0
diff --git a/dev-python/networkx/networkx-3.4_rc0.ebuild b/dev-python/networkx/networkx-3.4_rc0.ebuild
new file mode 100644
index 000000000000..b386d30100dd
--- /dev/null
+++ b/dev-python/networkx/networkx-3.4_rc0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_FULLY_TESTED=( python3_{10..13} )
+PYTHON_COMPAT=( "${PYTHON_FULLY_TESTED[@]}" )
+
+inherit distutils-r1 multiprocessing optfeature pypi virtualx
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="
+ https://networkx.org/
+ https://github.com/networkx/networkx/
+ https://pypi.org/project/networkx/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/lxml-4.6[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/matplotlib-3.7[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.24[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.11.2[${PYTHON_USEDEP}]
+ ' "${PYTHON_FULLY_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ if use x86 ; then
+ EPYTEST_DESELECT+=(
+ # https://github.com/networkx/networkx/issues/5913 (bug #921958)
+ networkx/algorithms/approximation/tests/test_traveling_salesman.py::test_asadpour_tsp
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # virtx implies nonfatal
+ nonfatal epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ # those examples use various assets and pre-compressed files
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ optfeature "recommended dependencies" "dev-python/matplotlib dev-python/numpy dev-python/pandas dev-python/scipy"
+ optfeature "graph drawing and graph layout algorithms" "dev-python/pygraphviz dev-python/pydot"
+ optfeature "YAML format reading and writing" "dev-python/pyyaml"
+ optfeature "shapefile format reading and writing" "sci-libs/gdal[python]"
+ optfeature "GraphML XML format" "dev-python/lxml"
+}