summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-01 23:08:09 -0400
committerMatt Turner <mattst88@gentoo.org>2022-07-01 23:08:09 -0400
commitb310943177ac1b3bedf6aa8a660778c002e8617b (patch)
tree5160bf84dfbdb2ef3f9ef538007473e05a403149 /app-accessibility/orca
parentnet-libs/libsoup: Version bump to 3.0.7 (diff)
downloadgentoo-b310943177ac1b3bedf6aa8a660778c002e8617b.tar.gz
gentoo-b310943177ac1b3bedf6aa8a660778c002e8617b.tar.bz2
gentoo-b310943177ac1b3bedf6aa8a660778c002e8617b.zip
app-accessibility/orca: Version bump to 42.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-42.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index c981dbdfbec3..cef98c821d54 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1 +1,2 @@
DIST orca-42.1.tar.xz 3700132 BLAKE2B 1310a1b43da709e9b273ce21374fff9fa30fbf08d1d0e171eb7eff4511ad5e2bcee12a2d6549a4c0c8e21526fb6f4b3b311d0e09fd6bfa863e29168809df9c10 SHA512 98f016087317666c4dcc7543d16ffb93214075d49d3708a1aa3dc8b6dd5d9d85c52dd31e650f4511371061c58d53e73455a09d6d7b4405b8a972b58ff1d7db91
+DIST orca-42.2.tar.xz 3707612 BLAKE2B a181c994ee8c35561d493dd00949807c09ccb3dd406ed0c61083c746c29fe7ef9db010484c34ca4416170cf51555b1f595f78816ca5f66ccf29970a0ff447088 SHA512 78c4e6d588d4929869100b761c85aa1d37a503e0960953c6ef7488ac7ed3c6d4ec400b9fd034b5178d64a69aca7daeaac2f25e292c32dfa814f7428b1c159fd5
diff --git a/app-accessibility/orca/orca-42.2.ebuild b/app-accessibility/orca/orca-42.2.ebuild
new file mode 100644
index 000000000000..b5714207dce1
--- /dev/null
+++ b/app-accessibility/orca/orca-42.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.34:2
+ >=app-accessibility/at-spi2-core-2.36:2[introspection]
+ >=dev-libs/atk-2.36
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ dev-libs/atk[introspection]
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}