summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-08-27 23:39:32 +0100
committerMarek Szuba <marecki@gentoo.org>2022-08-27 23:39:32 +0100
commit7206a86ea4c609c78dd83a06f3fd633740f49d66 (patch)
tree89c669377a9fbdf09049d097b80ba1c4f5bb8fbe /app-admin/ansible-lint
parentapp-admin/ansible-lint: add 6.5.1 (diff)
downloadgentoo-7206a86ea4c609c78dd83a06f3fd633740f49d66.tar.gz
gentoo-7206a86ea4c609c78dd83a06f3fd633740f49d66.tar.bz2
gentoo-7206a86ea4c609c78dd83a06f3fd633740f49d66.zip
app-admin/ansible-lint: drop 6.3.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin/ansible-lint')
-rw-r--r--app-admin/ansible-lint/Manifest1
-rw-r--r--app-admin/ansible-lint/ansible-lint-6.3.0.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 5c40d5275b33..b0e3cc496c55 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,3 +1,2 @@
-DIST ansible-lint-6.3.0.tar.gz 268331 BLAKE2B 00ea2dbc7bb5e71d63a737ac99d4116441f6b1eee2fa476d9aa4d78068064e53975df00950f337e7c9e25dacf8778ddd2e40eb5d3ea1301f56a80dfd90d42c20 SHA512 3e9d480cb90f3022a4b001c061c3e76b753620776a009b1563dce335c13ee38b7ac334725592ac644a2808d85ceb98b618a451c193bc7c4961474d4e7fbbb88e
DIST ansible-lint-6.4.0.gh.tar.gz 235346 BLAKE2B a2f55e6f4df739dccb011225f0a660978a9dfdbcc6e45cee2eef12467482c471d8700bb1bfad87e03eb1c4f21291307db5dc174e2440370ca11368f6ad6d195d SHA512 75e30a325a5c62f64066925b99e691886e299e029adc78fdceaa5eb23a74a46408793479e7c54c312d93e0a62d190b34f1e7614dec31a94822d39a231796e9df
DIST ansible-lint-6.5.1.gh.tar.gz 244320 BLAKE2B aff13d6ce9346dbdba459722cfc071b1e671dc17f3fb44744a706097f29e2a6a9962514fc61e669b58517acf6e95feba88af1bf8c7a4fb668e1a8d1cc5d54746 SHA512 40890a3fc0caaa3fd1d38f32739615dd664db1e7ea534c0bc3138da7295cdc6923715ea12febefc8951be350aad5bf7ac76dd004e3c4aff386b78551bd6442a8
diff --git a/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild b/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
deleted file mode 100644
index 4aea510b329c..000000000000
--- a/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
-HOMEPAGE="https://github.com/ansible/ansible-lint"
-# PyPI tarballs do not contain all the data files needed by the tests
-SRC_URI="https://github.com/ansible/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-RDEPEND="
- >=app-admin/ansible-base-2.12.0[${PYTHON_USEDEP}]
- >=dev-python/ansible-compat-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/enrich-1.2.6[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
- >=dev-python/ruamel-yaml-0.15.37[${PYTHON_USEDEP}]
- >=dev-python/wcmatch-7.0[${PYTHON_USEDEP}]
- >=dev-util/yamllint-1.25.0[${PYTHON_USEDEP}]"
-BDEPEND="
- >=dev-python/setuptools_scm-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/flaky-3.7.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.0.2_test-module-check.patch
-)
-
-# Skip problematic tests:
-# - test_call_from_outside_venv doesn't play nicely with the sandbox
-# - all the others require Internet access, mostly in order to access Ansible Galaxy
-EPYTEST_DESELECT=(
- test/test_cli_role_paths.py::test_run_playbook_github
- test/test_eco.py
- test/test_examples.py::test_custom_kinds
- test/test_import_playbook.py::test_task_hook_import_playbook
- test/test_list_rules.py::test_list_rules_includes_opt_in_rules
- test/test_list_rules.py::test_list_rules_with_format_option
- test/test_list_rules.py::test_list_tags_includes_opt_in_rules
- test/test_main.py::test_call_from_outside_venv
- test/test_prerun.py::test_install_collection
- test/test_prerun.py::test_prerun_reqs_v1
- test/test_prerun.py::test_prerun_reqs_v2
- test/test_prerun.py::test_require_collection_wrong_version
- test/test_rules_collection.py::test_rich_rule_listing
- test/test_utils.py::test_cli_auto_detect
- test/test_utils.py::test_template_lookup
- test/test_verbosity.py::test_default_verbosity
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- # As of 6.2.1, without this the test suite still gets confused by the presence of ansible-lint modules
- # in both ${ED} and ${S}.
- cd "${S}" || die
-
- epytest test
-}