summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2016-07-01 19:04:03 +0200
committerAmy Winston <amynka@gentoo.org>2016-07-01 19:04:03 +0200
commit99bc8b5524ba2542b22b81c8d5c1a4b431c23573 (patch)
treead896d438d49776c777a2b2500c8cfad1126a17a /app-crypt/eid-mw
parentdev-ruby/octokit: add missing test dep on mime-types (diff)
downloadgentoo-99bc8b5524ba2542b22b81c8d5c1a4b431c23573.tar.gz
gentoo-99bc8b5524ba2542b22b81c8d5c1a4b431c23573.tar.bz2
gentoo-99bc8b5524ba2542b22b81c8d5c1a4b431c23573.zip
app-crypt/eid-mw: eapi update bug #587250 by Vincent Hardy
- Move to EAPI 6 - add 1 new dependency - patch update gtk_not_required_9999.patch - add new patch not_zip_xpi_plugin.patch - add missing die Package-Manager: portage-2.2.28
Diffstat (limited to 'app-crypt/eid-mw')
-rw-r--r--app-crypt/eid-mw/eid-mw-9999.ebuild38
-rw-r--r--app-crypt/eid-mw/files/gtk_not_required_9999.patch22
-rw-r--r--app-crypt/eid-mw/files/not_zip_xpi_plugin.patch27
3 files changed, 63 insertions, 24 deletions
diff --git a/app-crypt/eid-mw/eid-mw-9999.ebuild b/app-crypt/eid-mw/eid-mw-9999.ebuild
index 2424341373a5..57bb7b83b7df 100644
--- a/app-crypt/eid-mw/eid-mw-9999.ebuild
+++ b/app-crypt/eid-mw/eid-mw-9999.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit eutils autotools mozextension multilib
+inherit autotools mozextension
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/Fedict/${PN}.git
https://github.com/Fedict/${PN}.git"
- inherit git-2
+ inherit git-r3
SRC_URI=""
else
MY_P="${P}-v${PV}"
@@ -29,8 +29,9 @@ IUSE="+gtk +xpi +dialogs"
REQUIRED_USE="
dialogs? ( gtk )"
-RDEPEND="gtk? ( x11-libs/gtk+:* )
+RDEPEND="gtk? ( x11-libs/gtk+:= )
>=sys-apps/pcsc-lite-1.2.9
+ net-libs/libproxy
xpi? ( || ( >=www-client/firefox-bin-3.6.24
>=www-client/firefox-3.6.20 ) )
!app-misc/beid-runtime"
@@ -39,21 +40,32 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
- use gtk || epatch "${FILESDIR}"/gtk_not_required_9999.patch
+ eapply_user
if [[ ${PV} == "9999" ]] ; then
+ use gtk || eapply "${FILESDIR}"/gtk_not_required_9999.patch
+
# Only in current git. Hopefully, in next release.
- sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac
- sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in
+ sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac || die
+ sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in || die
+ else
+ use gtk || eapply "${FILESDIR}"/gtk_not_required_4.1.4.patch
fi
if [[ ${PV} == "9999" ]] || ! use gtk ; then
eautoreconf
fi
+
+ # Do that after autoreconf (if autoreconf is required)
+ # This patch is not mandatory, it's just to do things properly :-)
+ eapply "${FILESDIR}"/not_zip_xpi_plugin.patch
}
src_configure() {
- econf $(use_enable dialogs) --disable-static
+ econf \
+ $(use_enable dialogs) \
+ --disable-static \
+ --disable-signed
}
src_install() {
@@ -61,19 +73,19 @@ src_install() {
if [[ ${PV} != "9999" ]] ; then
# Automatically done in current git. Hopefully, in next release.
- rm doc/sdk/include/rsaref220/win32.h
+ rm doc/sdk/include/rsaref220/win32.h || die
doheader -r doc/sdk/include/*
fi
if use xpi; then
declare MOZILLA_FIVE_HOME
if has_version '>=www-client/firefox-3.6.20'; then
MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
- xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
fi
if has_version '>=www-client/firefox-bin-3.6.24'; then
MOZILLA_FIVE_HOME="/opt/firefox"
- xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
fi
fi
- rm -r "${D}/usr/share" "${D}"/usr/lib*/*.la
+ rm -r "${D}/usr/share" "${D}"/usr/lib*/*.la || die
}
diff --git a/app-crypt/eid-mw/files/gtk_not_required_9999.patch b/app-crypt/eid-mw/files/gtk_not_required_9999.patch
index d5d6f1c550b9..f66ec182ca6c 100644
--- a/app-crypt/eid-mw/files/gtk_not_required_9999.patch
+++ b/app-crypt/eid-mw/files/gtk_not_required_9999.patch
@@ -1,13 +1,13 @@
diff --git a/Makefile.am b/Makefile.am
-index 1a605f7..6475886 100644
+index 65baf07..c264576 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
ACLOCAL_AMFLAGS = -I scripts/m4
EXTRA_DIST = scripts/build-aux/config.rpath debian build-debian.sh rpm doc
--SUBDIRS=cardcomm/pkcs11/src doc/sdk/include/rsaref220 tests/unit plugins_tools/xpi plugins_tools/aboutmw/gtk
-+SUBDIRS=cardcomm/pkcs11/src doc/sdk/include/rsaref220 tests/unit plugins_tools/xpi
+-SUBDIRS=cardcomm/pkcs11/src doc/sdk/include/rsaref220 plugins_tools/util tests/unit plugins_tools/xpi plugins_tools/aboutmw/gtk plugins_tools/eid-viewer
++SUBDIRS=cardcomm/pkcs11/src doc/sdk/include/rsaref220 plugins_tools/util tests/unit plugins_tools/xpi
xpipackage:
$(MAKE) -C plugins_tools/xpi xpipackage
@@ -54,18 +54,18 @@ index 6e33315..fce4494 100644
-
pkgconfig_DATA=libbeidpkcs11.pc
diff --git a/configure.ac b/configure.ac
-index 6f4b833..ec7ae8f 100644
+index 6485b23..a1f9c93 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -56,11 +56,6 @@ then
- fi
- fi
+@@ -59,11 +59,6 @@ fi
--if test x"$have_gtk" = "xno"
+ AC_DEFINE_UNQUOTED([HAVE_GTK], [$have_gtk], [Set to major version of libgtk])
+
+-if test "$have_gtk" = "no"
-then
- AC_MSG_ERROR([At least one version of GTK is required.])
-fi
-
- ###########################################################################
- ####### read user-specific requests from --enable directives ######
- ###########################################################################
+ PKG_CHECK_MODULES([XML2], [libxml-2.0])
+ PKG_CHECK_MODULES([libproxy], [libproxy-1.0])
+
diff --git a/app-crypt/eid-mw/files/not_zip_xpi_plugin.patch b/app-crypt/eid-mw/files/not_zip_xpi_plugin.patch
new file mode 100644
index 000000000000..4295543ea652
--- /dev/null
+++ b/app-crypt/eid-mw/files/not_zip_xpi_plugin.patch
@@ -0,0 +1,27 @@
+--- eid-mw-4.1.18-v4.1.18-a/plugins_tools/xpi/src/Makefile.in 2016-05-20 12:58:46.184002742 +0200
++++ eid-mw-4.1.18-v4.1.18-b/plugins_tools/xpi/src/Makefile.in 2016-06-18 16:18:57.467199895 +0200
+@@ -724,24 +724,6 @@
+ @SIGNED_TRUE@ cp $(srcdir)/belgiumeid-1.0.18.1-signed.1-signed.xpi $(XPI_ID).xpi
+
+ @SIGNED_FALSE@xpipackage: $(xpi_files)
+-# Create a temporary directory $tmp in $TMPDIR (default /tmp).
+-# Use mktemp if possible; otherwise fall back on mkdir,
+-# with $RANDOM to make collisions less likely.
+-@SIGNED_FALSE@ { \
+-@SIGNED_FALSE@ tmp=` \
+-@SIGNED_FALSE@ (umask 077 && mktemp -t -d "xpiXXXXXX") 2>/dev/null \
+-@SIGNED_FALSE@ ` && \
+-@SIGNED_FALSE@ test -n "$$tmp" && test -d "$$tmp"; \
+-@SIGNED_FALSE@ } || { \
+-@SIGNED_FALSE@ tmp=$$TMPDIR/xpi$$RANDOM; \
+-@SIGNED_FALSE@ umask 077 && $(mkinstalldirs) "$$tmp"; \
+-@SIGNED_FALSE@ } || exit $$?; \
+-@SIGNED_FALSE@ $(MAKE) DESTDIR=$$tmp extensionrootdir=/ install; \
+-@SIGNED_FALSE@ cd $$tmp; \
+-@SIGNED_FALSE@ rm -f $(abs_builddir)/$(XPI_NAME); \
+-@SIGNED_FALSE@ @ZIP@ -rq $(abs_builddir)/$(XPI_NAME) .; \
+-@SIGNED_FALSE@ cd -; \
+-@SIGNED_FALSE@ rm -rf $$tmp;
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.