summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-17 02:05:22 +0000
committerSam James <sam@gentoo.org>2024-11-17 02:05:22 +0000
commitd7b8916e46538241d5cb032a8264c4f6660f8964 (patch)
tree97fd9059162d20db7f0dea9828d98739e71cc8ca /app-crypt
parentsys-process/time: build with -std=gnu17 (diff)
downloadgentoo-d7b8916e46538241d5cb032a8264c4f6660f8964.tar.gz
gentoo-d7b8916e46538241d5cb032a8264c4f6660f8964.tar.bz2
gentoo-d7b8916e46538241d5cb032a8264c4f6660f8964.zip
app-crypt/pgpdump: fix C23 compat
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pgpdump/files/pgpdump-0.36-c23.patch35
-rw-r--r--app-crypt/pgpdump/pgpdump-0.36.ebuild1
2 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/pgpdump/files/pgpdump-0.36-c23.patch b/app-crypt/pgpdump/files/pgpdump-0.36-c23.patch
new file mode 100644
index 000000000000..70c4453a0993
--- /dev/null
+++ b/app-crypt/pgpdump/files/pgpdump-0.36-c23.patch
@@ -0,0 +1,35 @@
+https://github.com/kazu-yamamoto/pgpdump/pull/45
+
+From 541442dc04259bde680b46742522177be40cc065 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 17 Nov 2024 02:04:03 +0000
+Subject: [PATCH] Fix C23 compatibility
+
+C23 removes unprototyped functions, so fix the function pointer type.
+---
+ packet.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/packet.c b/packet.c
+index b6f3665..bdd3d3e 100644
+--- a/packet.c
++++ b/packet.c
+@@ -4,7 +4,7 @@
+
+ #include "pgpdump.h"
+
+-typedef void (*funcptr)();
++typedef void (*funcptr)(int);
+
+ private int get_new_len(int);
+ private int is_partial(int);
+@@ -91,7 +91,7 @@ TAG[] = {
+ #define TAG_NUM (sizeof(TAG) * sizeof(string))
+
+ private void
+-(*tag_func[])() = {
++(*tag_func[])(int) = {
+ Reserved,
+ Public_Key_Encrypted_Session_Key_Packet,
+ Signature_Packet,
+
diff --git a/app-crypt/pgpdump/pgpdump-0.36.ebuild b/app-crypt/pgpdump/pgpdump-0.36.ebuild
index b4695a9c1939..e835dec48598 100644
--- a/app-crypt/pgpdump/pgpdump-0.36.ebuild
+++ b/app-crypt/pgpdump/pgpdump-0.36.ebuild
@@ -17,6 +17,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-0.32-respect-ldflags.patch
+ "${FILESDIR}"/${PN}-0.36-c23.patch
)
src_install() {