summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-20 18:14:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-20 18:55:29 +0200
commit6ce25c39503cae5806f213ca58394ea6341abdf2 (patch)
tree013fc9e700b5c8d9865eb5ef700bb4c052fad58f /app-text
parentsys-kernel/gentoo-kernel-bin: Bump to 5.19.10 (diff)
downloadgentoo-6ce25c39503cae5806f213ca58394ea6341abdf2.tar.gz
gentoo-6ce25c39503cae5806f213ca58394ea6341abdf2.tar.bz2
gentoo-6ce25c39503cae5806f213ca58394ea6341abdf2.zip
app-text/paperwork-backend: Add missing test dependencies
This does not fix all of the test failures but gets some obvious ones out of the way. Closes: https://bugs.gentoo.org/866041 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/paperwork-backend/paperwork-backend-2.1.1-r1.ebuild (renamed from app-text/paperwork-backend/paperwork-backend-2.1.1.ebuild)20
1 files changed, 15 insertions, 5 deletions
diff --git a/app-text/paperwork-backend/paperwork-backend-2.1.1.ebuild b/app-text/paperwork-backend/paperwork-backend-2.1.1-r1.ebuild
index f5bcf8a9e058..5667253b8140 100644
--- a/app-text/paperwork-backend/paperwork-backend-2.1.1.ebuild
+++ b/app-text/paperwork-backend/paperwork-backend-2.1.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-DISTUTILS_USE_SETUPTOOLS=bdepend
+
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -14,9 +14,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="app-text/poppler[introspection]
+RDEPEND="
+ app-text/openpaperwork-core[${PYTHON_USEDEP}]
+ app-text/openpaperwork-gtk[${PYTHON_USEDEP}]
+ app-text/poppler[introspection]
dev-python/distro[${PYTHON_USEDEP}]
dev-python/Levenshtein[${PYTHON_USEDEP}]
dev-python/natsort[${PYTHON_USEDEP}]
@@ -28,6 +30,14 @@ RDEPEND="app-text/poppler[introspection]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/termcolor[${PYTHON_USEDEP}]
dev-python/whoosh[${PYTHON_USEDEP}]
- sci-libs/scikit-learn[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/libpillowfight[${PYTHON_USEDEP}]
+ media-libs/libinsane
+ )
+"
+
distutils_enable_tests unittest