summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-11-11 19:36:51 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-11 19:37:12 +0000
commitb64f44870960b1d321a911135687e332ab5d8ac5 (patch)
tree5ec823ea25bae201859712a62314a7756184ceb6 /dev-libs/libffi/files
parentx11-misc/fbpanel: Remove unnecessary gdk-pixbuf-xlib.h includes (diff)
downloadgentoo-b64f44870960b1d321a911135687e332ab5d8ac5.tar.gz
gentoo-b64f44870960b1d321a911135687e332ab5d8ac5.tar.bz2
gentoo-b64f44870960b1d321a911135687e332ab5d8ac5.zip
dev-libs/libffi: fix vendor detection on 'dash' shell
Reported-by: Paolo Pedroni Closes: https://bugs.gentoo.org/753299 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs/libffi/files')
-rw-r--r--dev-libs/libffi/files/libffi-3.3-compiler-vendor-quote.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libffi/files/libffi-3.3-compiler-vendor-quote.patch b/dev-libs/libffi/files/libffi-3.3-compiler-vendor-quote.patch
new file mode 100644
index 000000000000..db5b69ce2db9
--- /dev/null
+++ b/dev-libs/libffi/files/libffi-3.3-compiler-vendor-quote.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/753299
+--- a/testsuite/lib/libffi.exp
++++ b/testsuite/lib/libffi.exp
+@@ -287,9 +287,6 @@ proc libffi-init { args } {
+ verbose "libffi $blddirffi"
+
+ # Which compiler are we building with?
+- set tmp [grep "$blddirffi/config.log" "^ax_cv_c_compiler_vendor.*$"]
+- regexp -- {^[^=]*=(.*)$} $tmp nil compiler_vendor
+-
+ if { [string match $compiler_vendor "gnu"] } {
+ set gccdir [lookfor_file $tool_root_dir gcc/libgcc.a]
+ if {$gccdir != ""} {
+--- a/configure.ac
++++ b/configure.ac
+@@ -59,6 +59,7 @@ fi
+ cat > local.exp <<EOF
+ set CC_FOR_TARGET "$CC"
+ set CXX_FOR_TARGET "$CXX"
++set compiler_vendor "$ax_cv_c_compiler_vendor"
+ EOF
+
+ AM_MAINTAINER_MODE
+--- a/configure
++++ b/configure
+@@ -17402,6 +17402,7 @@ fi
+ cat > local.exp <<EOF
+ set CC_FOR_TARGET "$CC"
+ set CXX_FOR_TARGET "$CXX"
++set compiler_vendor "$ax_cv_c_compiler_vendor"
+ EOF
+
+