summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-06-08 17:10:16 +1200
committerKent Fredric <kentnl@gentoo.org>2018-06-08 17:15:59 +1200
commit96034222047dad5df4166757a5726140ff46a281 (patch)
tree06129365bd86d6acb2b808b565955cf88779d1f6 /dev-perl/Exception-Base
parentdev-perl/Encode-JIS2K: Cleanup old version 0.02 (diff)
downloadgentoo-96034222047dad5df4166757a5726140ff46a281.tar.gz
gentoo-96034222047dad5df4166757a5726140ff46a281.tar.bz2
gentoo-96034222047dad5df4166757a5726140ff46a281.zip
dev-perl/Exception-Base: Cleanup old version 0.250.0-r2
Package-Manager: Portage-2.3.29, Repoman-2.3.9
Diffstat (limited to 'dev-perl/Exception-Base')
-rw-r--r--dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild33
-rw-r--r--dev-perl/Exception-Base/Manifest1
-rw-r--r--dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch52
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild b/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild
deleted file mode 100644
index 352ab216de8a..000000000000
--- a/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MODULE_AUTHOR=DEXTER
-MODULE_VERSION=0.25
-inherit perl-module
-
-DESCRIPTION="Error handling with exception class"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-perl/Module-Build
- test? ( >=dev-perl/Test-Unit-Lite-0.120.0 )
-"
-
-SRC_TEST="do parallel"
-
-PATCHES=(
- "${FILESDIR}/${P}-sprintf.patch"
-)
-
-src_install(){
- perl-module_src_install
- docompress -x usr/share/doc/${PF}/examples
- insinto usr/share/doc/${PF}/
- doins -r examples/
-}
diff --git a/dev-perl/Exception-Base/Manifest b/dev-perl/Exception-Base/Manifest
index d2e478d237eb..c83b00359d12 100644
--- a/dev-perl/Exception-Base/Manifest
+++ b/dev-perl/Exception-Base/Manifest
@@ -1,2 +1 @@
-DIST Exception-Base-0.25.tar.gz 59534 BLAKE2B 1d5074c6566d2ecf840c323f17cef1a5b0663b5354fc8894ebe54833a1f6194ebceabbc2ce9a918c481b9ab656d44d3c455fd6125d7e9480a008afe80156192f SHA512 4bc416a8a4096b2149a205dc3129aabaa49bfa9f29746b31a09cbade01e15d53ed82649b75d69c508568a7fb12726e319360aba128102fdc1e0a7ba583473e65
DIST Exception-Base-0.2501.tar.gz 59965 BLAKE2B 9ec7e07596cece55153cfcf40fc95097c08bc8168b90164745374a6d639f93b2b4548b3cb7240bbb28113ef5b86feccea4637782432c10b2f469fe96a3b0d734 SHA512 848993b3d72f3a8f79467c69afdff848e61aed7d24977bafe4cfea56631a5c4746f9993330a4373a1c727f440c0cdc70e4001d7841f17125cf603772a6805acd
diff --git a/dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch b/dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch
deleted file mode 100644
index 656c3eba4ee3..000000000000
--- a/dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 1cb0ea6afd4bb76e5a1d759efe27ea0f18306a82 Mon Sep 17 00:00:00 2001
-From: Lee Johnson <lee@givengain.ch>
-Date: Thu, 1 Jan 2015 22:33:54 +0000
-Subject: [PATCH] resolve #1 - fix warnings new since perl 5.21.2
-
-Redundant argument in %s - this is because the various calls to the
-sprintf function offset the arrays by 1 (since the first element of
-the array is the sprintf string) but use @_ (the number of elements
-in the array) in the range: 1 .. @_
-
-since it's offset by 1 we are going beyond the end of the array and
-so sprintf consequently warns that we sent more arguments than it
-expected. fix this by using @_ -1 in the range (number of elements
-in the array minus 1)
----
- lib/Exception/Base.pm | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/lib/Exception/Base.pm b/lib/Exception/Base.pm
-index 8dce19f..096e2a5 100644
---- a/lib/Exception/Base.pm
-+++ b/lib/Exception/Base.pm
-@@ -1362,7 +1362,7 @@ sub matches { ## no critic qw(ProhibitExcessComplexity)
- local $_ = ref $self->{$key} eq 'ARRAY'
- ? sprintf(
- @{$self->{$key}}[0],
-- @{$self->{$key}}[1..@{$self->{$key}}]
-+ @{$self->{$key}}[1..@{$self->{$key}}-1]
- )
- : $self->{$key};
- if (ref $arrval eq 'CODE') {
-@@ -1393,7 +1393,7 @@ sub matches { ## no critic qw(ProhibitExcessComplexity)
- local $_ = ref $self->{$key} eq 'ARRAY'
- ? sprintf(
- @{$self->{$key}}[0],
-- @{$self->{$key}}[1..@{$self->{$key}}]
-+ @{$self->{$key}}[1..@{$self->{$key}}-1]
- )
- : $self->{$key};
-
-@@ -1613,7 +1613,7 @@ sub _string_attributes {
- my ($self) = @_;
-
- return map { ref $_ eq 'ARRAY'
-- ? sprintf(@$_[0], @$_[1..@$_])
-+ ? sprintf(@$_[0], @$_[1..@$_-1])
- : $_ }
- grep { defined $_ and (ref $_ or $_ ne '') }
- map { $self->{$_} }
---
-2.4.5
-