summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-17 06:44:59 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-17 07:10:23 +0100
commite89eec1963dc99db5bbf1e9652a3ef51ca5ab145 (patch)
tree584bd8ea3813cae9067dc97e2eda54495f4c93a4 /dev-python/Faker
parentdev-python/cfn-lint: Bump to 0.85.2 (diff)
downloadgentoo-e89eec1963dc99db5bbf1e9652a3ef51ca5ab145.tar.gz
gentoo-e89eec1963dc99db5bbf1e9652a3ef51ca5ab145.tar.bz2
gentoo-e89eec1963dc99db5bbf1e9652a3ef51ca5ab145.zip
dev-python/Faker: Bump to 23.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-23.2.1.ebuild40
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-23.2.1.ebuild b/dev-python/Faker/Faker-23.2.1.ebuild
new file mode 100644
index 000000000000..4a85c701f3c8
--- /dev/null
+++ b/dev-python/Faker/Faker-23.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+}
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 05945c117373..18948c7f6915 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -4,3 +4,4 @@ DIST Faker-22.7.0.tar.gz 1705221 BLAKE2B 9c41a053de75ca238399140531e7d37148ffa35
DIST Faker-23.0.0.tar.gz 1705271 BLAKE2B 0c83bf26ef1005a00c132e4634a617aef659cfb0ce59d67dd0d63d80371ab58b963417c5e26c5d8ef945bbb1a57db408424f0360327035844654e90338d49eff SHA512 f385c839d3d6cd5103e7a5e92dfda0581e1cd2e5e9270c678524ccaa7b97ddfc666423c2ae02605ed1d2c1c2a04dbda482323e40fb3c9854bf48b3208793f8d6
DIST Faker-23.1.0.tar.gz 1708228 BLAKE2B c72883e054b9e5e9f77de76ce354b7518038c055c6c034e091cbf89246a192c26896e427a9dd48981327498c8fcf63cd1b87b7e25647ce84606d4ba1bedfae51 SHA512 84fbf69d3911f21f98cd14926aad12c1da5be083c0820332bbd1212a995b7995960d7635b54f74b6ee125cfa8e81b991026647c46fa9035f6506bb8a853f4908
DIST Faker-23.2.0.tar.gz 1708429 BLAKE2B 053b8300ebae3c1b1012c5314305e57e224c0fd46893d29063fc1fcf763aaf985b242e8d028185031c68d1735d4155ecbb6241bc96b12e7fa279ad4ca7ca34e1 SHA512 7046f66f344dc9bbe4c8ee8586aae8c03e7eaac4e472e08b8f10206cde40a2741ed9ac2891239e61fc9a4cfee5590caff086ca065d833c58517a2476573c494c
+DIST Faker-23.2.1.tar.gz 1708603 BLAKE2B 94759727bb7feb520d51c3a52e50e01bad164cc3f262620d9f106f4746e68b298447d678dba7a5af9a80d0fdd7d9981f57ca50e27ab10671caec52c34e0442ee SHA512 1fefc84bed97e012c4e07117d62a6e0970e1be9d1c2b6f09db497b0d5ba66a2b2b0f3ba806926621d59dc0753a8b8c9caacefa15fbb23c755f110c5ef908975d