summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-04 00:15:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-04 00:15:16 +0100
commit7e257ac6cc1a94fb08801f7326a7db5c959b5d89 (patch)
treebed553cd0a00b5dbd5a9affbf08d6c9512475ee5 /dev-python/bsddb3
parentdev-python/pypy: Backport secfixes (diff)
downloadgentoo-7e257ac6cc1a94fb08801f7326a7db5c959b5d89.tar.gz
gentoo-7e257ac6cc1a94fb08801f7326a7db5c959b5d89.tar.bz2
gentoo-7e257ac6cc1a94fb08801f7326a7db5c959b5d89.zip
dev-python/bsddb3: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bsddb3')
-rw-r--r--dev-python/bsddb3/Manifest1
-rw-r--r--dev-python/bsddb3/bsddb3-6.2.7.ebuild68
-rw-r--r--dev-python/bsddb3/files/bsddb3-6.2.7-py39.patch19
3 files changed, 0 insertions, 88 deletions
diff --git a/dev-python/bsddb3/Manifest b/dev-python/bsddb3/Manifest
index 24805577e20b..89e5bbf12b38 100644
--- a/dev-python/bsddb3/Manifest
+++ b/dev-python/bsddb3/Manifest
@@ -1,2 +1 @@
-DIST bsddb3-6.2.7.tar.gz 437325 BLAKE2B ed7931a32766338c5674cc017a8528d30acf9397443f270bf93974c9ed7ae4abdc6b704d85d48f68e0c4b6d85c4ad71edf891e342e5f9b9a597453140adde742 SHA512 edd85fb697142ac152a10a299899c52b637a3b1e3d28d913c61f9de91ef292fc2055daeb18fca62242284b4189a61d5bf318aca6e2966849879043a46db000e0
DIST bsddb3-6.2.9.tar.gz 230475 BLAKE2B 68c7c498d581dd5ca860060a3152f7ae135bbc75d00714764446d071e8ea88d303a73d1aa411db1ff8fc922aa6d486632fe38bef3596550150ed511a97fc9c9c SHA512 9e878ef865cba608fafe4274b660234927b9106323c3e4ddd728682b0f11b3c7edb9a3dd56cdfe8665eba890df4121695c9710b95bb2f43b8a0be3ec4050f61e
diff --git a/dev-python/bsddb3/bsddb3-6.2.7.ebuild b/dev-python/bsddb3/bsddb3-6.2.7.ebuild
deleted file mode 100644
index baea2b392f2b..000000000000
--- a/dev-python/bsddb3/bsddb3-6.2.7.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit db-use distutils-r1
-
-DESCRIPTION="Python bindings for Berkeley DB"
-HOMEPAGE="https://www.jcea.es/programacion/pybsddb.htm https://pypi.org/project/bsddb3/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- <sys-libs/db-6.3:=
- || (
- sys-libs/db:6.2
- sys-libs/db:6.1
- sys-libs/db:5.3
- sys-libs/db:5.1
- sys-libs/db:4.8
- sys-libs/db:4.7
- )"
-DEPEND="${RDEPEND}"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
- "${FILESDIR}"/${P}-py39.patch
-)
-
-python_prepare_all() {
- # This list should be kept in sync with setup.py.
- if [[ -z ${DB_VER} ]]; then
- for DB_VER in 6.2 6.1 5.3 5.1 4.8 4.7; do
- has_version "sys-libs/db:${DB_VER}" && break
- done
- fi
-
- # Force version.
- sed -e "s/db_ver = None/db_ver = (${DB_VER%.*}, ${DB_VER#*.})/" \
- -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
- -i setup2.py setup3.py || die
-
- # Adjust test.py to look in build/lib.
- sed -e "s/'lib.%s' % PLAT_SPEC/'lib'/" \
- -i test2.py test3.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- # These are needed for both build and install.
- export BERKELEYDB_DIR="${EPREFIX}/usr"
- export BERKELEYDB_INCDIR="$(db_includedir ${DB_VER})"
- export BERKELEYDB_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
- export YES_I_HAVE_THE_RIGHT_TO_USE_THIS_BERKELEY_DB_VERSION=1
-}
-
-python_test() {
- PYTHONPATH=Lib3 "${EPYTHON}" test3.py -v || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/bsddb3/files/bsddb3-6.2.7-py39.patch b/dev-python/bsddb3/files/bsddb3-6.2.7-py39.patch
deleted file mode 100644
index 77d4626912af..000000000000
--- a/dev-python/bsddb3/files/bsddb3-6.2.7-py39.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/Lib3/bsddb/test/test_replication.py b/Lib3/bsddb/test/test_replication.py
-index 2fd6aa0..9d78241 100644
---- a/Lib3/bsddb/test/test_replication.py
-+++ b/Lib3/bsddb/test/test_replication.py
-@@ -105,8 +105,12 @@ class DBReplication(unittest.TestCase) :
-
- class DBReplicationManager(DBReplication) :
- def test01_basic_replication(self) :
-- master_port = test_support.find_unused_port()
-- client_port = test_support.find_unused_port()
-+ try:
-+ from test.support.socket_helper import find_unused_port
-+ except ImportError:
-+ find_unused_port = test_support.find_unused_port
-+ master_port = find_unused_port()
-+ client_port = find_unused_port()
- if db.version() >= (5, 2) :
- self.site = self.dbenvMaster.repmgr_site("127.0.0.1", master_port)
- self.site.set_config(db.DB_GROUP_CREATOR, True)