summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/buildutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/buildutils')
-rw-r--r--dev-python/buildutils/Manifest1
-rw-r--r--dev-python/buildutils/buildutils-0.3-r1.ebuild51
-rw-r--r--dev-python/buildutils/files/buildutils-0.3-pudge_addcommand.patch12
-rw-r--r--dev-python/buildutils/metadata.xml8
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/buildutils/Manifest b/dev-python/buildutils/Manifest
new file mode 100644
index 000000000000..e21840e2b89b
--- /dev/null
+++ b/dev-python/buildutils/Manifest
@@ -0,0 +1 @@
+DIST buildutils-0.3.tar.gz 47868 SHA256 8f9921cf145a1879986b4028db0af4f028f65fe6eae29936490174037ba7dfc5 SHA512 63e3c0e9737672abcb7f9b10909df69f93eb801eeb829f840aaabc37428fc640ed7df4232283f933e5f0bb80b0195624b1ba69aeba1b01b7a61250bf6e6b6421 WHIRLPOOL b2ee8a3e1b70e82a563edd01b0d175c8c5670183ef4a0bbe207c6fd1a0bfdaf5797d30b57a6729a4ea61a5e3a2c88b5f859461439be69f2fe9ac9a91470b4a71
diff --git a/dev-python/buildutils/buildutils-0.3-r1.ebuild b/dev-python/buildutils/buildutils-0.3-r1.ebuild
new file mode 100644
index 000000000000..bf9377ba4298
--- /dev/null
+++ b/dev-python/buildutils/buildutils-0.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Extensions for developing Python libraries and applications"
+HOMEPAGE="http://buildutils.lesscode.org http://pypi.python.org/pypi/buildutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/pudge[$(python_gen_usedep python{2_6,2_7})] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_prepare_all() {
+ # Enable pudge command.
+ epatch "${FILESDIR}/${P}-pudge_addcommand.patch"
+ sed -e "s/buildutils.command.publish/buildutils.publish_command.publish/" \
+ -i buildutils/test/test_publish.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ # ensure docs are built with py2
+ if "${PYTHON}" -c "import pudge"; then
+ "${PYTHON}" setup.py pudge || die "Generation of documentation failed"
+ else
+ die "Generation of documentation failed"
+ fi
+ fi
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/buildutils/files/buildutils-0.3-pudge_addcommand.patch b/dev-python/buildutils/files/buildutils-0.3-pudge_addcommand.patch
new file mode 100644
index 000000000000..a9cadcaa42b8
--- /dev/null
+++ b/dev-python/buildutils/files/buildutils-0.3-pudge_addcommand.patch
@@ -0,0 +1,12 @@
+--- setup.cfg 2008-04-05 17:18:24.000000000 +0300
++++ setup.cfg 2008-04-05 17:18:46.000000000 +0300
+@@ -1,6 +1,9 @@
+ [checksum]
+ sign = 1
+
++[global]
++command_packages = buildutils.pudge_command
++
+ [egg_info]
+ tag_build =
+ tag_date = 0
diff --git a/dev-python/buildutils/metadata.xml b/dev-python/buildutils/metadata.xml
new file mode 100644
index 000000000000..cb9268c07fe6
--- /dev/null
+++ b/dev-python/buildutils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">buildutils</remote-id>
+ </upstream>
+</pkgmetadata>