summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-17 08:34:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-17 09:22:29 +0200
commit01c4255bb5a13889cf64d8c6b91dc034109f5c21 (patch)
tree55dc43892e0a386b20acfb5849723fc6d2a78e81 /dev-python/emoji
parentdev-python/confuse: Bump to 2.0.0 (diff)
downloadgentoo-01c4255bb5a13889cf64d8c6b91dc034109f5c21.tar.gz
gentoo-01c4255bb5a13889cf64d8c6b91dc034109f5c21.tar.bz2
gentoo-01c4255bb5a13889cf64d8c6b91dc034109f5c21.zip
dev-python/emoji: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/emoji')
-rw-r--r--dev-python/emoji/Manifest1
-rw-r--r--dev-python/emoji/emoji-2.0.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/emoji/Manifest b/dev-python/emoji/Manifest
index f7755f08c621..5f20f083acb5 100644
--- a/dev-python/emoji/Manifest
+++ b/dev-python/emoji/Manifest
@@ -1 +1,2 @@
DIST emoji-1.7.0.gh.tar.gz 217487 BLAKE2B 8b78e73604769bb6d5d0882a44ae8d9b6ca9de0d5fe0d4b0077cbc4a89949d4ece578de19de5b2db18c6f630dfe0adb5d9554874ce382d5624d9cf95c024ebcc SHA512 837e97cb80c15e980329e25e9fe2960063bb59e410ceb564abf95b90f7f2251e37092b701524a5b14dd7c4bd530a08b69f77bc8e4b7e53c6b8c5898ec384fc5a
+DIST emoji-2.0.0.gh.tar.gz 245417 BLAKE2B 9c28a3ed0c9151930d1f37453eff6cdac1d4e5b0b6294a0c7eed2befe3884f3c54b88a20bcf62c1b5a37551607063bfd53cbd9d5b4d9b1a36b446e1815d64052 SHA512 5e33cfcf11d9d30453eeec55428d466a88c4332fc04bc185e6f2d00995e71f086771d1923a574905b6d3b46b7f8b675d0a6474526b45be6e6443b1ffdca007c8
diff --git a/dev-python/emoji/emoji-2.0.0.ebuild b/dev-python/emoji/emoji-2.0.0.ebuild
new file mode 100644
index 000000000000..20469a0482c6
--- /dev/null
+++ b/dev-python/emoji/emoji-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Emoji for Python"
+HOMEPAGE="
+ https://github.com/carpedm20/emoji/
+ https://pypi.org/project/emoji/
+"
+SRC_URI="
+ https://github.com/carpedm20/emoji/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+distutils_enable_tests pytest