summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-02 23:35:55 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-03 00:12:59 +0100
commita041328d60f86eaeadcecbbc544c1995e8824ab6 (patch)
tree0e0f5291bf88471fb7c0b828c4966eade74824c4 /dev-python/google-api-python-client
parentdev-python/rich: Bump to 10.15.2 (diff)
downloadgentoo-a041328d60f86eaeadcecbbc544c1995e8824ab6.tar.gz
gentoo-a041328d60f86eaeadcecbbc544c1995e8824ab6.tar.bz2
gentoo-a041328d60f86eaeadcecbbc544c1995e8824ab6.zip
dev-python/google-api-python-client: Bump to 2.32.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.32.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index efc6b2a48e2c..cd9c4260b302 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1 +1,2 @@
DIST google-api-python-client-2.31.0.tar.gz 27822400 BLAKE2B 447d97ec10376c1a9e911023051b8e3e278db782f91e0e4c1eb72f4ba54db0498439fca42633bc9fdf16ac2982a286103d6d7a99b701b0ff30e024e131b5e175 SHA512 80359f415e2ec4c42b7e12aa333d91849a4246fd744ec627397099be261176add44bf4ada875bc353729bbbca589be59e6cad3810f609d9d23f9fb458bf2c69e
+DIST google-api-python-client-2.32.0.tar.gz 27954196 BLAKE2B 1863735d3862a11b3fce3dc270442b9cd5612375062ee447be07baa35578668db53d8415e7c88ad29b9c6ede02113686ba7ea6b994bfb6b2b72bb2bf5139c86f SHA512 2a9300020ec28da02ae689b4527fcfea6f3f78131a5431a3c3720dae1868bfa76871330685fdb4403328cc21736099fe8e346cfbf215e19f8cb00d1f5d1707f6
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.32.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.32.0.ebuild
new file mode 100644
index 000000000000..94711a2ec4c1
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.32.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ epytest tests
+}