summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-03 20:24:45 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-07 06:29:09 +0100
commit3c8764c65c1a5c5b08fbce1deec73b6048cb3f72 (patch)
treee9a409f33902f80905d98c60c7eee81648d53990 /dev-python/numpy
parentdev-python/pyrate-limiter: Use EPYTEST_XDIST (diff)
downloadgentoo-3c8764c65c1a5c5b08fbce1deec73b6048cb3f72.tar.gz
gentoo-3c8764c65c1a5c5b08fbce1deec73b6048cb3f72.tar.bz2
gentoo-3c8764c65c1a5c5b08fbce1deec73b6048cb3f72.zip
dev-python/numpy: Switch to EPYTEST_XDIST
Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/33667 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/numpy-1.26.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/numpy/numpy-1.26.1.ebuild b/dev-python/numpy/numpy-1.26.1.ebuild
index 3255d05e2c00..955652eea0d8 100644
--- a/dev-python/numpy/numpy-1.26.1.ebuild
+++ b/dev-python/numpy/numpy-1.26.1.ebuild
@@ -9,7 +9,7 @@ PYTHON_COMPAT=( python3_{10..12} pypy3 )
PYTHON_REQ_USE="threads(+)"
FORTRAN_NEEDED=lapack
-inherit distutils-r1 flag-o-matic fortran-2 multiprocessing pypi toolchain-funcs
+inherit distutils-r1 flag-o-matic fortran-2 pypi toolchain-funcs
DESCRIPTION="Fast array and numerical python library"
HOMEPAGE="
@@ -46,11 +46,11 @@ BDEPEND="
' 'python*')
dev-python/charset-normalizer[${PYTHON_USEDEP}]
>=dev-python/hypothesis-5.8.0[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
)
"
+EPYTEST_XDIST=1
distutils_enable_tests pytest
python_prepare_all() {
@@ -143,7 +143,7 @@ python_test() {
esac
rm -rf numpy || die
- epytest -n "$(makeopts_jobs)" --pyargs numpy
+ epytest --pyargs numpy
}
python_install_all() {