summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-10-02 21:24:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-10-02 21:34:05 +0300
commit1a2cbfa2a686fd49b14aa97ae10e532bb86b3b4a (patch)
tree55d677f2ebb28227ee69e25b575426b3a710794d /dev-python/pocketlint
parentdev-python/jedi: add 0.19.1 (diff)
downloadgentoo-1a2cbfa2a686fd49b14aa97ae10e532bb86b3b4a.tar.gz
gentoo-1a2cbfa2a686fd49b14aa97ae10e532bb86b3b4a.tar.bz2
gentoo-1a2cbfa2a686fd49b14aa97ae10e532bb86b3b4a.zip
dev-python/pocketlint: add 0.25
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pocketlint')
-rw-r--r--dev-python/pocketlint/Manifest1
-rw-r--r--dev-python/pocketlint/pocketlint-0.25.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pocketlint/Manifest b/dev-python/pocketlint/Manifest
index b01a4686a894..04cc4273f1ac 100644
--- a/dev-python/pocketlint/Manifest
+++ b/dev-python/pocketlint/Manifest
@@ -1 +1,2 @@
DIST pocketlint-0.24.gh.tar.gz 23875 BLAKE2B b4699d1f0633ed6a3f84b97db972818c00a1d382a48648fd4fe6870f4c54f983fd36366f85a409a99b860f385902a9a05adec63199e35d1264a522a7a3086e31 SHA512 21c4055dd42c244760950b64ec4cd9359fc589014953be6f9296e0265101f098fbe34351e87f92630751fa0055de20281974a04b425f691acc4608cf929d4bf4
+DIST pocketlint-0.25.gh.tar.gz 23931 BLAKE2B e8254477223ea0e631129778cc760ef57d34adb78f783258c8c097f7eac1acfe4cb00d21bc9aff576fbfab2bb3f7b687de33b3bc1f02c8d083d690a2e392bbac SHA512 dcb21ee147839a606520370f948594fc695c779a03d9edfb054dd6c07f4dd1c4ad0b64ccaad504da01e3b6c572ce27db8813ac8b61468d43e3745b5053a4edb7
diff --git a/dev-python/pocketlint/pocketlint-0.25.ebuild b/dev-python/pocketlint/pocketlint-0.25.ebuild
new file mode 100644
index 000000000000..c3bc7b176957
--- /dev/null
+++ b/dev-python/pocketlint/pocketlint-0.25.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Shared code for running pylint against rhinstaller projects"
+HOMEPAGE="
+ https://github.com/rhinstaller/pocketlint/
+ https://pypi.org/project/pocketlint/
+"
+SRC_URI="
+ https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests/pylint/runpylint.py || die "test failed with ${EPYTHON}"
+}