summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 22:18:13 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 22:18:13 +0100
commit4afca1749e93c4abc66e3ae1674a4316c996abb8 (patch)
tree1d73666e2967c0208faf3d3a342a5b515c78acc1 /dev-python/pymountboot
parentdev-python/pymountboot: Remove the live ebuild (diff)
downloadgentoo-4afca1749e93c4abc66e3ae1674a4316c996abb8.tar.gz
gentoo-4afca1749e93c4abc66e3ae1674a4316c996abb8.tar.bz2
gentoo-4afca1749e93c4abc66e3ae1674a4316c996abb8.zip
dev-python/pymountboot: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pymountboot')
-rw-r--r--dev-python/pymountboot/pymountboot-0.2.3-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pymountboot/pymountboot-0.2.3-r1.ebuild b/dev-python/pymountboot/pymountboot-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..073ad8efd08a
--- /dev/null
+++ b/dev-python/pymountboot/pymountboot-0.2.3-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension module to (re)mount /boot"
+HOMEPAGE="https://github.com/mgorny/pymountboot/"
+SRC_URI="
+ https://github.com/mgorny/pymountboot/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=sys-apps/util-linux-2.20"
+DEPEND="${RDEPEND}"