summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-16 08:11:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-16 08:11:41 +0200
commitd4346cb27b1976b6faa4eabb14d2478940d219f9 (patch)
tree245269da562d3f31f23305f2c050306ff09455cf /dev-python/python-dateutil
parentdev-python/python-backoff: Remove old (diff)
downloadgentoo-d4346cb27b1976b6faa4eabb14d2478940d219f9.tar.gz
gentoo-d4346cb27b1976b6faa4eabb14d2478940d219f9.tar.bz2
gentoo-d4346cb27b1976b6faa4eabb14d2478940d219f9.zip
dev-python/python-dateutil: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-dateutil')
-rw-r--r--dev-python/python-dateutil/Manifest1
-rw-r--r--dev-python/python-dateutil/files/0001-zoneinfo-Get-timezone-data-from-system-tzdata-r1.patch104
-rw-r--r--dev-python/python-dateutil/python-dateutil-2.8.1-r3.ebuild54
3 files changed, 0 insertions, 159 deletions
diff --git a/dev-python/python-dateutil/Manifest b/dev-python/python-dateutil/Manifest
index 8781f6a62fc0..e719bccf5703 100644
--- a/dev-python/python-dateutil/Manifest
+++ b/dev-python/python-dateutil/Manifest
@@ -1,2 +1 @@
-DIST python-dateutil-2.8.1.tar.gz 331745 BLAKE2B 9785fe93976d9bbe21d6610133e37e558cdde4062a1a738ccbf2bf80aa062882ba59c60f2b9bfc44c53e0f8fc4b5ebdd5d12b6ba54a60706576360e453b2f160 SHA512 337000216e0f8ce32d6363768444144183ab9268f69082f20858f2b3322b1c449e53b2f2b5dcb3645be22294659ce7838f74ace2fd7a7c4f2adc6cf806a9fa2c
DIST python-dateutil-2.8.2.tar.gz 357324 BLAKE2B 060f97280b63ed70e6d83fa5696af6dc3c729cdf5bc48c7a90e3e59eb0cc0360e5205536685550330d64ecc9b6e40ca12888409d6819dd136b17a67add2ec4e8 SHA512 6538858e4a3e2d1de1bf25b6d8b25e3a8d20bf60fb85e32d07ac491c90ce193e268bb5641371b8a79fb0f033a184bac9896b3bc643c1aca9ee9c6478286ac20c
diff --git a/dev-python/python-dateutil/files/0001-zoneinfo-Get-timezone-data-from-system-tzdata-r1.patch b/dev-python/python-dateutil/files/0001-zoneinfo-Get-timezone-data-from-system-tzdata-r1.patch
deleted file mode 100644
index abbc853e0902..000000000000
--- a/dev-python/python-dateutil/files/0001-zoneinfo-Get-timezone-data-from-system-tzdata-r1.patch
+++ /dev/null
@@ -1,104 +0,0 @@
-From f48e70ae846c161dfbfe6ddb36e4bcad4427ac8c Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 3 Apr 2018 22:03:32 +0200
-Subject: [PATCH] zoneinfo: Get timezone data from system tzdata
-
----
- dateutil/test/test_imports.py | 3 +--
- dateutil/zoneinfo/__init__.py | 25 ++++++++++++++-----------
- 2 files changed, 15 insertions(+), 13 deletions(-)
-
-diff --git a/dateutil/test/test_imports.py b/dateutil/test/test_imports.py
-index 2a19b62..97d07e4 100644
---- a/dateutil/test/test_imports.py
-+++ b/dateutil/test/test_imports.py
-@@ -158,9 +158,8 @@ class ImportZoneInfoTest(unittest.TestCase):
- def testZoneinfoStar(self):
- from dateutil.zoneinfo import gettz
- from dateutil.zoneinfo import gettz_db_metadata
-- from dateutil.zoneinfo import rebuild
-
-- zi_all = (gettz, gettz_db_metadata, rebuild)
-+ zi_all = (gettz, gettz_db_metadata)
-
- for var in zi_all:
- self.assertIsNot(var, None)
-diff --git a/dateutil/zoneinfo/__init__.py b/dateutil/zoneinfo/__init__.py
-index 34f11ad..e9870ca 100644
---- a/dateutil/zoneinfo/__init__.py
-+++ b/dateutil/zoneinfo/__init__.py
-@@ -1,6 +1,7 @@
- # -*- coding: utf-8 -*-
- import warnings
- import json
-+import os
-
- from tarfile import TarFile
- from pkgutil import get_data
-@@ -10,7 +11,7 @@ from dateutil.tz import tzfile as _tzfile
-
- __all__ = ["get_zonefile_instance", "gettz", "gettz_db_metadata"]
-
--ZONEFILENAME = "dateutil-zoneinfo.tar.gz"
-+ZONEDIRECTORY = "/usr/share/zoneinfo"
- METADATA_FN = 'METADATA'
-
-
-@@ -19,12 +20,14 @@ class tzfile(_tzfile):
- return (gettz, (self._filename,))
-
-
--def getzoneinfofile_stream():
-- try:
-- return BytesIO(get_data(__name__, ZONEFILENAME))
-- except IOError as e: # TODO switch to FileNotFoundError?
-- warnings.warn("I/O error({0}): {1}".format(e.errno, e.strerror))
-- return None
-+def iter_zones(topdir):
-+ for dirpath, dirnames, filenames in os.walk(topdir):
-+ for f in filenames:
-+ if f.endswith(('.list', '.tab', '.zi', 'leapseconds')):
-+ continue
-+ fpath = os.path.join(dirpath, f)
-+ relpath = os.path.relpath(fpath, topdir)
-+ yield (relpath, tzfile(fpath, filename=relpath))
-
-
- class ZoneInfoFile(object):
-@@ -48,7 +51,7 @@ class ZoneInfoFile(object):
- # no metadata in tar file
- self.metadata = None
- else:
-- self.zones = {}
-+ self.zones = dict(iter_zones(ZONEDIRECTORY))
- self.metadata = None
-
- def get(self, name, default=None):
-@@ -99,7 +102,7 @@ def get_zonefile_instance(new_instance=False):
- zif = getattr(get_zonefile_instance, '_cached_instance', None)
-
- if zif is None:
-- zif = ZoneInfoFile(getzoneinfofile_stream())
-+ zif = ZoneInfoFile()
-
- get_zonefile_instance._cached_instance = zif
-
-@@ -140,7 +143,7 @@ def gettz(name):
- DeprecationWarning)
-
- if len(_CLASS_ZONE_INSTANCE) == 0:
-- _CLASS_ZONE_INSTANCE.append(ZoneInfoFile(getzoneinfofile_stream()))
-+ _CLASS_ZONE_INSTANCE.append(ZoneInfoFile())
- return _CLASS_ZONE_INSTANCE[0].zones.get(name)
-
-
-@@ -163,5 +166,5 @@ def gettz_db_metadata():
- DeprecationWarning)
-
- if len(_CLASS_ZONE_INSTANCE) == 0:
-- _CLASS_ZONE_INSTANCE.append(ZoneInfoFile(getzoneinfofile_stream()))
-+ _CLASS_ZONE_INSTANCE.append(ZoneInfoFile())
- return _CLASS_ZONE_INSTANCE[0].metadata
---
-2.17.0
-
diff --git a/dev-python/python-dateutil/python-dateutil-2.8.1-r3.ebuild b/dev-python/python-dateutil/python-dateutil-2.8.1-r3.ebuild
deleted file mode 100644
index 214b011d5bae..000000000000
--- a/dev-python/python-dateutil/python-dateutil-2.8.1-r3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Extensions to the standard Python datetime module"
-HOMEPAGE="
- https://dateutil.readthedocs.io/
- https://pypi.org/project/python-dateutil/
- https://github.com/dateutil/dateutil/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
-RDEPEND="
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- sys-libs/timezone-data
-"
-BDEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/0001-zoneinfo-Get-timezone-data-from-system-tzdata-r1.patch"
- "${FILESDIR}/python-dateutil-2.8.1-no-pytest-cov.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # don't install zoneinfo tarball
- sed -i '/package_data=/d' setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_prepare() {
- if [[ ${EPYTHON} == python3.7 ]]; then
- # these tests are flakey on 3.7
- rm dateutil/test/property/test_{parser,isoparse}_prop.py || die
- fi
-}