summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-31 22:05:19 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-31 22:09:42 +0200
commit528e7775352d18ebc9ab94d04caa8609ebbf94a9 (patch)
treecf8b6574836cc15b001f6d88c9d31ba85116259d /dev-python/testfixtures
parentdev-python/subunit: drop 1.4.0 (diff)
downloadgentoo-528e7775352d18ebc9ab94d04caa8609ebbf94a9.tar.gz
gentoo-528e7775352d18ebc9ab94d04caa8609ebbf94a9.tar.bz2
gentoo-528e7775352d18ebc9ab94d04caa8609ebbf94a9.zip
dev-python/testfixtures: drop 6.18.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-6.18.2.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 75c6272ec1b0..6925357657c3 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1,2 +1 @@
-DIST testfixtures-6.18.2.tar.gz 122026 BLAKE2B 2b30c03ae71a300883ace52dc80e06c6b6610283687fa8df4ded1678991a47e8186de57060458a2fe98fc8eeb8fae8299081697a6471bdedcca2772405c91c6d SHA512 ee27d9944e8e8ec770199b115a50274f7167e9d3d3d866b0d0bbe7fec8a939b25a469ecac0158aaa486b129e078077c5822e7500ad473f98ba59862424413e15
DIST testfixtures-6.18.3.tar.gz 122142 BLAKE2B 014cc2245d5fbe0d39310c8e2c21cd5f289d6ec7a6a561d055e86d4cd25b79f1aa535067746219e2382df2aeec050dfa24cdae674636d92ee61016fa9861e705 SHA512 e556e7cb28f122526ef19550b1e593b61f01923d0be53951344f917f89b3d4cae29e525ceda3d0290bc18c3641b509dd7236e7b55ae50da0157fe11ca9f04cca
diff --git a/dev-python/testfixtures/testfixtures-6.18.2.ebuild b/dev-python/testfixtures/testfixtures-6.18.2.ebuild
deleted file mode 100644
index 0be51f64725c..000000000000
--- a/dev-python/testfixtures/testfixtures-6.18.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
-HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/sybil[${PYTHON_USEDEP}]
- >=dev-python/twisted-18[${PYTHON_USEDEP}]
- dev-python/zope-component[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/Simplistix/testfixtures/commit/8fb2122eea0f1d0de1ccca7a3a0f5426bc6d4964
- "${FILESDIR}/testfixtures-6.18.1-py3.10.patch"
-)
-
-python_prepare_all() {
- # kill weird way of declaring build deps
- sed -e '/build=/d' -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTHONPATH="."
- local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
- epytest -Wignore::DeprecationWarning
-}