summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-10-29 13:33:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-10-29 13:40:32 -0500
commit9f2e73347ce997e5d8f0d2ceef8c5fddb419842a (patch)
treef77ac87d17327b0311043c1729bec5d8831faada /dev-python/virtualenvwrapper
parentdev-python/virtualenv-clone: support py36 as well (diff)
downloadgentoo-9f2e73347ce997e5d8f0d2ceef8c5fddb419842a.tar.gz
gentoo-9f2e73347ce997e5d8f0d2ceef8c5fddb419842a.tar.bz2
gentoo-9f2e73347ce997e5d8f0d2ceef8c5fddb419842a.zip
dev-python/virtualenvwrapper: 4.8.2 bup
Package-Manager: Portage-2.3.8, Repoman-2.3.4
Diffstat (limited to 'dev-python/virtualenvwrapper')
-rw-r--r--dev-python/virtualenvwrapper/Manifest1
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/virtualenvwrapper/Manifest b/dev-python/virtualenvwrapper/Manifest
index f743c8bea78e..2f953f8d9ee6 100644
--- a/dev-python/virtualenvwrapper/Manifest
+++ b/dev-python/virtualenvwrapper/Manifest
@@ -1 +1,2 @@
DIST virtualenvwrapper-4.7.1.tar.gz 89930 SHA256 3bf73ede42a689adeedc8ac85662cb539665d3d029459bc8d3e6835ecd81ffde SHA512 f972179992728b8b600388b34562fa9de355f526e4ee25ea88840700a57f196a60eba91ac3137e7d826925c7a8ade7479af383bcbfb8b9b837d0a374b8b3c4fd WHIRLPOOL c56cab31ec89b8dd5bfeb7949f72b2d5c5e6f40543bc7fa960b03edcc9d3c2ec095335eecf0b40adcc0fd1c92efc1e760748db772a3da0c44591ed7de5248880
+DIST virtualenvwrapper-4.8.2.tar.gz 91331 SHA256 18d8e4c500c4c4ee794f704e050cf2bbb492537532a4521d1047e7dd1ee4e374 SHA512 53d92f653b988873da5a46e316a40ef767d97f75072e311aa4a8ae45c8aabb49569e36cc35597f9bdfc1f883a51eb648d5f01f4ea8b3237fae30a21dca67d7bc WHIRLPOOL dd775b98a7f4e143c847ad985b65141a385a862e49e364c1087dbd924ee1aaa088be2d35e23314b333f2909be4d6492496c6ed956ad865d48172b7429bb1f7fe
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2.ebuild
new file mode 100644
index 000000000000..3cf33e1ade92
--- /dev/null
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of extensions to Ian Bicking's virtualenv tool"
+HOMEPAGE="
+ http://www.doughellmann.com/projects/virtualenvwrapper
+ https://pypi.python.org/pypi/virtualenvwrapper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# testsuite doesn't work out of the box. Demand of a virtualenv outstrips setup by the eclass
+RESTRICT=test
+
+RDEPEND="
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+
+python_test() {
+ bash ./tests/run_tests || die "Tests failed under ${EPYTHON}"
+}