summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-11-15 18:10:20 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-11-15 19:14:47 -0500
commit221865a1afcddfe95dc5ef3825c8f0682547f0d3 (patch)
treea458940487351de58e81c0ae47a0ffead9f1f92e /dev-qt/qt-creator
parentkde-misc/colord-kde: Fix IUSE=-X (diff)
downloadgentoo-221865a1afcddfe95dc5ef3825c8f0682547f0d3.tar.gz
gentoo-221865a1afcddfe95dc5ef3825c8f0682547f0d3.tar.bz2
gentoo-221865a1afcddfe95dc5ef3825c8f0682547f0d3.zip
dev-qt/qt-creator: update live
Not much to update, but next release is close and checking state. Tests pass except tst_utils_deviceshell which is failing in upstream's CI as well (unless QTC_USE_QPROCESS=false). The change causing this is not included in 12.0.0rc1 though, so not going to worry about it. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qt-creator')
-rw-r--r--dev-qt/qt-creator/files/qt-creator-12.0.0-musl-no-malloc-trim.patch8
-rw-r--r--dev-qt/qt-creator/qt-creator-9999.ebuild6
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-qt/qt-creator/files/qt-creator-12.0.0-musl-no-malloc-trim.patch b/dev-qt/qt-creator/files/qt-creator-12.0.0-musl-no-malloc-trim.patch
new file mode 100644
index 000000000000..b22f20425129
--- /dev/null
+++ b/dev-qt/qt-creator/files/qt-creator-12.0.0-musl-no-malloc-trim.patch
@@ -0,0 +1,8 @@
+malloc_trim() is unavailable with musl
+--- a/src/plugins/coreplugin/icore.cpp
++++ b/src/plugins/coreplugin/icore.cpp
+@@ -1276,3 +1276,3 @@
+ // glibc may not actually free memory in free().
+-#ifdef Q_OS_LINUX
++#if defined(Q_OS_LINUX) && defined(__GLIBC__)
+ connect(&m_trimTimer, &QTimer::timeout, this, [] { malloc_trim(0); });
diff --git a/dev-qt/qt-creator/qt-creator-9999.ebuild b/dev-qt/qt-creator/qt-creator-9999.ebuild
index 2680f1244fe9..ab3ca9782f99 100644
--- a/dev-qt/qt-creator/qt-creator-9999.ebuild
+++ b/dev-qt/qt-creator/qt-creator-9999.ebuild
@@ -81,7 +81,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-11.0.2-musl-no-execinfo.patch
- "${FILESDIR}"/${PN}-11.0.2-musl-no-malloc-trim.patch
+ "${FILESDIR}"/${PN}-12.0.0-musl-no-malloc-trim.patch
)
llvm_check_deps() {
@@ -120,7 +120,7 @@ src_configure() {
# Much can be optional, but do not want to flood users (or maintainers)
# with too many flags. Not to mention that many plugins are merely
- # wrappers around still optional tools (e.g. cvs) and any unwanted
+ # wrappers around still optional tools (e.g. git) and any unwanted
# plugins can be disabled at runtime. So optional flags are limited
# to plugins with additional build-time dependencies.
-DBUILD_LIBRARY_TRACING=$(usex tracing) # qml+perfprofiler,ctfvisual
@@ -234,12 +234,12 @@ Utilities:
- Conan (dev-util/conan)
- Docker (app-containers/docker)
- Haskell (dev-lang/ghc)
+- ScreenRecorder (media-video/ffmpeg)
- SerialTerminal (USE=serialterminal)
- SilverSearcher (sys-apps/the_silver_searcher)
- StudioWelcome (USE=qmldesigner)
Version Control:
-- CVS (dev-vcs/cvs)
- Fossil (dev-vcs/fossil)
- Git (dev-vcs/git)
- Mercurial (dev-vcs/mercurial)