summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-20 09:28:47 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-20 10:19:54 -0400
commit7efa35f2e3c99336bb910985071bc26691a7f64b (patch)
tree18b96bbfc2785532fc3ccd76b16b684cacc70f37 /dev-qt/qtspeech
parentdev-qt/qttools: use QT6_RESTRICT_TESTS (diff)
downloadgentoo-7efa35f2e3c99336bb910985071bc26691a7f64b.tar.gz
gentoo-7efa35f2e3c99336bb910985071bc26691a7f64b.tar.bz2
gentoo-7efa35f2e3c99336bb910985071bc26691a7f64b.zip
dev-qt/qtspeech: use QT6_RESTRICT_TESTS
This one should be more or less temporary, albeit haven't tried it in a a while and may as well remove IUSE="test" entirely for now which may have its own problems. I'd rather not worry about this one yet. Bug: https://bugs.gentoo.org/930266 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtspeech')
-rw-r--r--dev-qt/qtspeech/qtspeech-6.7.0.ebuild13
-rw-r--r--dev-qt/qtspeech/qtspeech-6.7.9999.ebuild13
-rw-r--r--dev-qt/qtspeech/qtspeech-6.9999.ebuild13
3 files changed, 15 insertions, 24 deletions
diff --git a/dev-qt/qtspeech/qtspeech-6.7.0.ebuild b/dev-qt/qtspeech/qtspeech-6.7.0.ebuild
index 5491997f2898..4a4f7916dee2 100644
--- a/dev-qt/qtspeech/qtspeech-6.7.0.ebuild
+++ b/dev-qt/qtspeech/qtspeech-6.7.0.ebuild
@@ -3,6 +3,11 @@
EAPI=8
+# tests are kind of flaky, sometimes hang, and also fail with clang
+# (not that it's unusable with clang) -- may be worth revisiting
+# eventually given qtspeech is still somewhat new (added in 6.4.0)
+QT6_RESTRICT_TESTS=1
+
inherit qt6-build
DESCRIPTION="Text-to-speech library for the Qt6 framework"
@@ -15,14 +20,6 @@ IUSE="flite qml +speechd"
# can build with neither, but then it is just mock tts and may be confusing
REQUIRED_USE="|| ( flite speechd )"
-# TODO: tests are known failing with clang and needs looking into, albeit
-# it is still usable at runtime save for applications segfaulting on exit
-# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
-# of this). Restricting because also seen this result in hanging. Note that
-# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
-# status on new major versions.
-RESTRICT="test"
-
RDEPEND="
~dev-qt/qtbase-${PV}:6
~dev-qt/qtmultimedia-${PV}:6
diff --git a/dev-qt/qtspeech/qtspeech-6.7.9999.ebuild b/dev-qt/qtspeech/qtspeech-6.7.9999.ebuild
index 52d658ae0a12..c012be997560 100644
--- a/dev-qt/qtspeech/qtspeech-6.7.9999.ebuild
+++ b/dev-qt/qtspeech/qtspeech-6.7.9999.ebuild
@@ -3,6 +3,11 @@
EAPI=8
+# tests are kind of flaky, sometimes hang, and also fail with clang
+# (not that it's unusable with clang) -- may be worth revisiting
+# eventually given qtspeech is still somewhat new (added in 6.4.0)
+QT6_RESTRICT_TESTS=1
+
inherit qt6-build
DESCRIPTION="Text-to-speech library for the Qt6 framework"
@@ -15,14 +20,6 @@ IUSE="flite qml +speechd"
# can build with neither, but then it is just mock tts and may be confusing
REQUIRED_USE="|| ( flite speechd )"
-# TODO: tests are known failing with clang and needs looking into, albeit
-# it is still usable at runtime save for applications segfaulting on exit
-# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
-# of this). Restricting because also seen this result in hanging. Note that
-# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
-# status on new major versions.
-RESTRICT="test"
-
RDEPEND="
~dev-qt/qtbase-${PV}:6
~dev-qt/qtmultimedia-${PV}:6
diff --git a/dev-qt/qtspeech/qtspeech-6.9999.ebuild b/dev-qt/qtspeech/qtspeech-6.9999.ebuild
index 52d658ae0a12..c012be997560 100644
--- a/dev-qt/qtspeech/qtspeech-6.9999.ebuild
+++ b/dev-qt/qtspeech/qtspeech-6.9999.ebuild
@@ -3,6 +3,11 @@
EAPI=8
+# tests are kind of flaky, sometimes hang, and also fail with clang
+# (not that it's unusable with clang) -- may be worth revisiting
+# eventually given qtspeech is still somewhat new (added in 6.4.0)
+QT6_RESTRICT_TESTS=1
+
inherit qt6-build
DESCRIPTION="Text-to-speech library for the Qt6 framework"
@@ -15,14 +20,6 @@ IUSE="flite qml +speechd"
# can build with neither, but then it is just mock tts and may be confusing
REQUIRED_USE="|| ( flite speechd )"
-# TODO: tests are known failing with clang and needs looking into, albeit
-# it is still usable at runtime save for applications segfaulting on exit
-# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
-# of this). Restricting because also seen this result in hanging. Note that
-# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
-# status on new major versions.
-RESTRICT="test"
-
RDEPEND="
~dev-qt/qtbase-${PV}:6
~dev-qt/qtmultimedia-${PV}:6