summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-15 00:56:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-16 00:12:14 +0100
commitf85385e4bf45d1e5af44a1b494c914a9f2020887 (patch)
treef6e2b2204f34294f6b49dc3013abf0d693a71565 /dev-qt
parentapp-admin/metalog: EAPI=6 (diff)
downloadgentoo-f85385e4bf45d1e5af44a1b494c914a9f2020887.tar.gz
gentoo-f85385e4bf45d1e5af44a1b494c914a9f2020887.tar.bz2
gentoo-f85385e4bf45d1e5af44a1b494c914a9f2020887.zip
dev-qt/qtwebkit: Fix pkgconfig
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-cmake-fix-pkgconfig_deps-spelling.patch97
-rw-r--r--dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-fix-pkgconfig.patch29
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.212.0_pre20180120.ebuild6
3 files changed, 131 insertions, 1 deletions
diff --git a/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-cmake-fix-pkgconfig_deps-spelling.patch b/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-cmake-fix-pkgconfig_deps-spelling.patch
new file mode 100644
index 000000000000..a460cec609bc
--- /dev/null
+++ b/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-cmake-fix-pkgconfig_deps-spelling.patch
@@ -0,0 +1,97 @@
+From 326604b27878566d581ea8c1991abd280453a75b Mon Sep 17 00:00:00 2001
+From: Andrew Webster <awebster@arcx.com>
+Date: Tue, 20 Mar 2018 09:08:00 -0400
+Subject: [PATCH] [cmake] Make spelling for PKGCONFIG_DEPS consistent
+
+It was referenced as PKGCONGIG_DEPS and PKGCONFIG_DEPS which left
+Qt5WebKitWidgets with empty dependencies. Correcting to
+PKGCONFIG_DEPS gives it the proper dependencies.
+
+Qt5WebKit was already working, but the spelling has also been
+corrected to avoid confusion.
+---
+ Source/WebKit/PlatformQt.cmake | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/Source/WebKit/PlatformQt.cmake b/Source/WebKit/PlatformQt.cmake
+index 28976b611cd8..de3eabab1157 100644
+--- a/Source/WebKit/PlatformQt.cmake
++++ b/Source/WebKit/PlatformQt.cmake
+@@ -427,7 +427,7 @@ install(
+ COMPONENT Data
+ )
+
+-set(WEBKIT_PKGCONGIG_DEPS "Qt5Core Qt5Gui Qt5Network")
++set(WEBKIT_PKGCONFIG_DEPS "Qt5Core Qt5Gui Qt5Network")
+ set(WEBKIT_PRI_DEPS "core gui network")
+ set(WEBKIT_PRI_EXTRA_LIBS "")
+ set(WEBKIT_PRI_RUNTIME_DEPS "core_private gui_private")
+@@ -448,11 +448,11 @@ if (USE_MEDIA_FOUNDATION)
+ set(WEBKIT_PRI_EXTRA_LIBS "-lmfuuid -lstrmiids ${WEBKIT_PRI_EXTRA_LIBS}")
+ endif ()
+ if (USE_QT_MULTIMEDIA)
+- set(WEBKIT_PKGCONGIG_DEPS "${WEBKIT_PKGCONGIG_DEPS} Qt5Multimedia")
++ set(WEBKIT_PKGCONFIG_DEPS "${WEBKIT_PKGCONFIG_DEPS} Qt5Multimedia")
+ set(WEBKIT_PRI_RUNTIME_DEPS "multimedia ${WEBKIT_PRI_RUNTIME_DEPS}")
+ endif ()
+
+-set(WEBKITWIDGETS_PKGCONGIG_DEPS "${WEBKIT_PKGCONGIG_DEPS} Qt5Widgets Qt5WebKit")
++set(WEBKITWIDGETS_PKGCONFIG_DEPS "${WEBKIT_PKGCONGIG_DEPS} Qt5Widgets Qt5WebKit")
+ set(WEBKITWIDGETS_PRI_DEPS "${WEBKIT_PRI_DEPS} widgets webkit")
+ set(WEBKITWIDGETS_PRI_RUNTIME_DEPS "${WEBKIT_PRI_RUNTIME_DEPS} widgets_private")
+
+@@ -465,12 +465,12 @@ if (ENABLE_PRINT_SUPPORT)
+ endif ()
+
+ if (USE_QT_MULTIMEDIA)
+- set(WEBKITWIDGETS_PKGCONGIG_DEPS "${WEBKITWIDGETS_PKGCONGIG_DEPS} Qt5MultimediaWidgets")
++ set(WEBKITWIDGETS_PKGCONFIG_DEPS "${WEBKITWIDGETS_PKGCONFIG_DEPS} Qt5MultimediaWidgets")
+ set(WEBKITWIDGETS_PRI_RUNTIME_DEPS "${WEBKITWIDGETS_PRI_RUNTIME_DEPS} multimediawidgets")
+ endif ()
+
+ if (QT_STATIC_BUILD)
+- set(WEBKITWIDGETS_PKGCONGIG_DEPS "${WEBKITWIDGETS_PKGCONGIG_DEPS} Qt5PrintSupport")
++ set(WEBKITWIDGETS_PKGCONFIG_DEPS "${WEBKITWIDGETS_PKGCONFIG_DEPS} Qt5PrintSupport")
+ set(WEBKITWIDGETS_PRI_DEPS "${WEBKITWIDGETS_PRI_DEPS} printsupport")
+ set(EXTRA_LIBS_NAMES WebCore JavaScriptCore WTF)
+ append_lib_names_to_list(EXTRA_LIBS_NAMES ${LIBXML2_LIBRARIES} ${SQLITE_LIBRARIES} ${ZLIB_LIBRARIES} ${JPEG_LIBRARIES} ${PNG_LIBRARIES})
+@@ -494,7 +494,7 @@ if (QT_STATIC_BUILD)
+ endif ()
+ list(REMOVE_DUPLICATES EXTRA_LIBS_NAMES)
+ foreach (LIB_NAME ${EXTRA_LIBS_NAMES})
+- set(WEBKIT_PKGCONGIG_DEPS "${WEBKIT_PKGCONGIG_DEPS} ${LIB_PREFIX}${LIB_NAME}")
++ set(WEBKIT_PKGCONFIG_DEPS "${WEBKIT_PKGCONFIG_DEPS} ${LIB_PREFIX}${LIB_NAME}")
+ set(WEBKIT_PRI_EXTRA_LIBS "${WEBKIT_PRI_EXTRA_LIBS} -l${LIB_PREFIX}${LIB_NAME}")
+ endforeach ()
+ endif ()
+@@ -504,7 +504,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
+ BASE_NAME Qt5WebKit
+ DESCRIPTION "Qt WebKit module"
+ INCLUDE_INSTALL_DIR "${KDE_INSTALL_INCLUDEDIR}/QtWebKit"
+- DEPS "${WEBKIT_PKGCONGIG_DEPS}"
++ DEPS "${WEBKIT_PKGCONFIG_DEPS}"
+ FILENAME_VAR WebKit_PKGCONFIG_FILENAME
+ )
+ set(ECM_PKGCONFIG_INSTALL_DIR "${LIB_INSTALL_DIR}/pkgconfig" CACHE PATH "The directory where pkgconfig will be installed to.")
+From 8c76aabf062232c3fb26839b76716006eca44eec Mon Sep 17 00:00:00 2001
+From: Andrew Webster <awebster@arcx.com>
+Date: Tue, 20 Mar 2018 10:33:59 -0400
+Subject: [PATCH] [cmake] Another PKGCONFIG_DEPS correction
+
+---
+ Source/WebKit/PlatformQt.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Source/WebKit/PlatformQt.cmake b/Source/WebKit/PlatformQt.cmake
+index de3eabab1157..6ab441b98d29 100644
+--- a/Source/WebKit/PlatformQt.cmake
++++ b/Source/WebKit/PlatformQt.cmake
+@@ -452,7 +452,7 @@ if (USE_QT_MULTIMEDIA)
+ set(WEBKIT_PRI_RUNTIME_DEPS "multimedia ${WEBKIT_PRI_RUNTIME_DEPS}")
+ endif ()
+
+-set(WEBKITWIDGETS_PKGCONFIG_DEPS "${WEBKIT_PKGCONGIG_DEPS} Qt5Widgets Qt5WebKit")
++set(WEBKITWIDGETS_PKGCONFIG_DEPS "${WEBKIT_PKGCONFIG_DEPS} Qt5Widgets Qt5WebKit")
+ set(WEBKITWIDGETS_PRI_DEPS "${WEBKIT_PRI_DEPS} widgets webkit")
+ set(WEBKITWIDGETS_PRI_RUNTIME_DEPS "${WEBKIT_PRI_RUNTIME_DEPS} widgets_private")
+
diff --git a/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-fix-pkgconfig.patch b/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-fix-pkgconfig.patch
new file mode 100644
index 000000000000..e5d7796ee142
--- /dev/null
+++ b/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-fix-pkgconfig.patch
@@ -0,0 +1,29 @@
+From fbd1de045999d1e5b5dcae7ac6c1e674ac0044fe Mon Sep 17 00:00:00 2001
+From: Dmitry Shachnev <mitya57@gmail.com>
+Date: Sat, 24 Feb 2018 15:09:53 +0300
+Subject: [PATCH] [cmake] Fix include dir in the generated pkg-config files
+
+---
+ Source/WebKit/PlatformQt.cmake | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Source/WebKit/PlatformQt.cmake b/Source/WebKit/PlatformQt.cmake
+index 6fe440be800c..28976b611cd8 100644
+--- a/Source/WebKit/PlatformQt.cmake
++++ b/Source/WebKit/PlatformQt.cmake
+@@ -503,6 +503,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
+ ecm_generate_pkgconfig_file(
+ BASE_NAME Qt5WebKit
+ DESCRIPTION "Qt WebKit module"
++ INCLUDE_INSTALL_DIR "${KDE_INSTALL_INCLUDEDIR}/QtWebKit"
+ DEPS "${WEBKIT_PKGCONGIG_DEPS}"
+ FILENAME_VAR WebKit_PKGCONFIG_FILENAME
+ )
+@@ -728,6 +729,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
+ ecm_generate_pkgconfig_file(
+ BASE_NAME Qt5WebKitWidgets
+ DESCRIPTION "Qt WebKitWidgets module"
++ INCLUDE_INSTALL_DIR "${KDE_INSTALL_INCLUDEDIR}/QtWebKitWidgets"
+ DEPS "${WEBKITWIDGETS_PKGCONFIG_DEPS}"
+ FILENAME_VAR WebKitWidgets_PKGCONFIG_FILENAME
+ )
diff --git a/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20180120.ebuild b/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20180120.ebuild
index cee7596f99c8..d520d1f87ea0 100644
--- a/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20180120.ebuild
+++ b/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20180120.ebuild
@@ -76,7 +76,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${COMMIT}
-PATCHES=( "${FILESDIR}/${P}-functional.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-functional.patch"
+ "${FILESDIR}/${P}-fix-pkgconfig.patch"
+ "${FILESDIR}/${P}-cmake-fix-pkgconfig_deps-spelling.patch"
+)
CHECKREQS_DISK_BUILD="16G" # bug 417307