summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-07-20 13:20:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-07-20 13:23:16 +0200
commitcfc8fa175f286a57d8055de9681f6070e19bd365 (patch)
treed67e234352755edc91a1165b2cbb40de024d2f4d /dev-ros/test_roscpp/files
parentdev-ros/test_roscpp: Remove old (diff)
downloadgentoo-cfc8fa175f286a57d8055de9681f6070e19bd365.tar.gz
gentoo-cfc8fa175f286a57d8055de9681f6070e19bd365.tar.bz2
gentoo-cfc8fa175f286a57d8055de9681f6070e19bd365.zip
dev-ros/test_roscpp: upstream boost fix
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_roscpp/files')
-rw-r--r--dev-ros/test_roscpp/files/boost.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/test_roscpp/files/boost.patch b/dev-ros/test_roscpp/files/boost.patch
new file mode 100644
index 000000000000..41bac154d6ce
--- /dev/null
+++ b/dev-ros/test_roscpp/files/boost.patch
@@ -0,0 +1,26 @@
+commit 41f18edc9f2f0b1ef304ea25f148bd56a6bf3d70
+Author: Maarten de Vries <maarten@de-vri.es>
+Date: Thu Jan 31 00:58:29 2019 +0100
+
+ Remove signals from find_package(Boost COMPONENTS ...) (#1580)
+
+ The packages use signals2, not signals. Only boost libraries with
+ compiled code should be passed to find_package(Boost COMPONENTS ...),
+ and the signals2 library has always been header only.
+
+ Boost 1.69 has removed the deprecated signals library, so the otherwise
+ useless but harmless `signals` component now breaks the build.
+
+diff --git a/test/test_roscpp/CMakeLists.txt b/test/test_roscpp/CMakeLists.txt
+index 519767362..01c3d6672 100644
+--- a/test/test_roscpp/CMakeLists.txt
++++ b/test/test_roscpp/CMakeLists.txt
+@@ -11,7 +11,7 @@ find_package(catkin REQUIRED COMPONENTS
+ )
+
+ if(CATKIN_ENABLE_TESTING)
+- find_package(Boost REQUIRED COMPONENTS signals filesystem system)
++ find_package(Boost REQUIRED COMPONENTS filesystem system)
+
+ include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
+