summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-19 08:06:26 +0100
committerHans de Graaff <graaff@gentoo.org>2023-03-19 08:14:43 +0100
commitccbc4d21724c741041bc0820585a8ff315163854 (patch)
tree9844b3d8a6864b8238398de647cc3acd0786f34f /dev-ruby/text-hyphen
parentdev-ruby/ruby-gtk2: add 3.5.1 (diff)
downloadgentoo-ccbc4d21724c741041bc0820585a8ff315163854.tar.gz
gentoo-ccbc4d21724c741041bc0820585a8ff315163854.tar.bz2
gentoo-ccbc4d21724c741041bc0820585a8ff315163854.zip
dev-ruby/text-hyphen: add 1.5.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/text-hyphen')
-rw-r--r--dev-ruby/text-hyphen/Manifest1
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.5.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/text-hyphen/Manifest b/dev-ruby/text-hyphen/Manifest
index 60c5601b1b0d..a58f959cf317 100644
--- a/dev-ruby/text-hyphen/Manifest
+++ b/dev-ruby/text-hyphen/Manifest
@@ -1 +1,2 @@
DIST text-hyphen-1.4.1.gem 751616 BLAKE2B 4a6d6a9b430c2dee2a486dde9f49405b98bc32fe8f96448c0cbe8d55f416c4e4e9bef5ae3adb57576dee6fa285680fc57b958cb279786872c8d95282cbf72e73 SHA512 4a6667aff01e56afce79302f46d0afdbf9c965ad80dbf9a7266a213143e6b6bc2cb00092d26900286bf72a700e47be6b0860cfdf87fa2856477db02261f9ef3d
+DIST text-hyphen-1.5.0.gem 836096 BLAKE2B 702363b99c33e614dab5b2509d0b77e5f37ca2f401e2c13fab466aec5bbc4f24247fe306ed6f7ed16c3e3b8cad35ca5948725175759827ec9a1b45642a7399ea SHA512 7390b057f0fe4918aa98811adc3922bf6b959aedbf327a035324fc92935675f8016574519d0ff34e11c24bc4b8fe0d110b296344ed8a7cfae018ca5a7d6ce5c9
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.5.0.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.5.0.ebuild
new file mode 100644
index 000000000000..f19b311a4a1b
--- /dev/null
+++ b/dev-ruby/text-hyphen/text-hyphen-1.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md History.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hyphenates words according to the rules of the language the word is written in"
+HOMEPAGE="https://rubygems.org/gems/text-hyphen"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-2.8.0
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '2igem "test-unit", ">= 2.0"' test/test_*.rb || die
+}