summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-03-04 07:48:28 +0100
committerHans de Graaff <graaff@gentoo.org>2024-03-04 07:48:46 +0100
commitc94e73914097263b1ac4884424ed20b15f118fc8 (patch)
treede72e452e11be492525d62f230de14e282b6f0d0 /dev-ruby
parentdev-ruby/deckar01-task_list: add 2.3.4 (diff)
downloadgentoo-c94e73914097263b1ac4884424ed20b15f118fc8.tar.gz
gentoo-c94e73914097263b1ac4884424ed20b15f118fc8.tar.bz2
gentoo-c94e73914097263b1ac4884424ed20b15f118fc8.zip
dev-ruby/ruby-prof: add 1.7.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-prof/Manifest1
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-1.7.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index d720f090100a..7a913905280d 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1 +1,2 @@
DIST ruby-prof-1.6.3.tgz 247407 BLAKE2B aac1ec36ee274faba919aa04be625b7b97ef61df105266f3d1b629cef6948db0bffbe67e70782f90a059221cb11cdb0df18031c9061f84cc882029cdde84629f SHA512 3172251fbd445c73f0eec734e09021ec0e375fd2f2999ec357569c679aa98ea5e0e08a18be1236e2572a8f0c302a1157d6a0d36ef04dffc4d0767accce629118
+DIST ruby-prof-1.7.0.tgz 251253 BLAKE2B e9cc60591d5cb8b3be528ba57c6374e7965b2f23394d468f3eb62a547e50edc7cc4ea99a6985726a30f063a0ce4823863b468e0ef2c89ef58cfbbe0362bfdb96 SHA512 ecea55a2a77d832f4aeca73aab578372a57a4fdf2cfc4db1fb14a899fed35ddfac79a078ab8207af8a4e70cdd0c4bb1e44a9ead8642e06b27ac4214d7d5981ef
diff --git a/dev-ruby/ruby-prof/ruby-prof-1.7.0.ebuild b/dev-ruby/ruby-prof/ruby-prof-1.7.0.ebuild
new file mode 100644
index 000000000000..5de91d47156c
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-1.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="ruby-prof.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ruby_prof/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
+SRC_URI="https://github.com/ruby-prof/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Avoid bundler
+ sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
+
+ sed -i -e '2igem "test-unit"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
+
+ # Avoid unneeded dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
+
+ # Don't strip library by default
+ sed -i -e '/LDFLAGS/ s/-s//' ext/ruby_prof/extconf.rb || die
+}