summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/git-sh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/git-sh')
-rw-r--r--dev-vcs/git-sh/Manifest2
-rw-r--r--dev-vcs/git-sh/git-sh-1.1.ebuild32
-rw-r--r--dev-vcs/git-sh/git-sh-1.3.ebuild32
-rw-r--r--dev-vcs/git-sh/metadata.xml12
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-vcs/git-sh/Manifest b/dev-vcs/git-sh/Manifest
new file mode 100644
index 000000000000..14811dbd282e
--- /dev/null
+++ b/dev-vcs/git-sh/Manifest
@@ -0,0 +1,2 @@
+DIST git-sh-1.1.tar.gz 26616 SHA256 2947304d328c9db77268840e29eb19abba7252f84b98f1d5ea957c8b906638ab SHA512 c6704b7340b2da5ca1a0484461cbf6f51c2428254f036254aa6bd2577b8e492ab65dbf7b2c7b2e6c944e3f9df9f3fb8bdca768ed7ce7a26554c821bc3f231882 WHIRLPOOL 22b578c631130bf3f951daf20258b356dfed48a69595383dbf0cbe6ecd6861940a721c03763511b45cf3f25d6334df9f4b85f63b989990343f8618c715bbfcb0
+DIST git-sh-1.3.tar.gz 26757 SHA256 461848dfa52ea6dd6cd0a374c52404b632204dc637cde17c0532529107d52358 SHA512 8ab742d0ff86e8387d03e2e190eec8ffd4725b1bfa58940f6673f5eac8c749931e3b3f8f20b898d933db36f56b323f800dba47a35294f865f456512f19a7846c WHIRLPOOL 01cd40187e0fe5930c1f53fba9708bc56ed14db20a5ecda897bdef1fe8a36bcfddda317a6cddef9297deb8956592c5003f15516afe22b9175354d4f0ac9b4aa4
diff --git a/dev-vcs/git-sh/git-sh-1.1.ebuild b/dev-vcs/git-sh/git-sh-1.1.ebuild
new file mode 100644
index 000000000000..8c8bc46bc2f5
--- /dev/null
+++ b/dev-vcs/git-sh/git-sh-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vcs-snapshot
+
+DESCRIPTION="A customized bash environment suitable for git work"
+HOMEPAGE="http://github.com/rtomayko/git-sh"
+SRC_URI="http://github.com/rtomayko/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ sed \
+ -e 's/git-completion\.bash //' \
+ -e 's:/local::' -i Makefile || die "sed failed"
+}
+
+pkg_postinst() {
+ echo
+ einfo "For bash completion in git commands emerge dev-vcs/git"
+ einfo "with bash-completion USE flag."
+ echo
+}
diff --git a/dev-vcs/git-sh/git-sh-1.3.ebuild b/dev-vcs/git-sh/git-sh-1.3.ebuild
new file mode 100644
index 000000000000..aa5998fb69ab
--- /dev/null
+++ b/dev-vcs/git-sh/git-sh-1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vcs-snapshot
+
+DESCRIPTION="A customized bash environment suitable for git work"
+HOMEPAGE="http://github.com/rtomayko/git-sh"
+SRC_URI="https://github.com/rtomayko/git-sh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ sed \
+ -e 's/git-completion\.bash //' \
+ -e 's:/local::' -i Makefile || die "sed failed"
+}
+
+pkg_postinst() {
+ echo
+ einfo "For bash completion in git commands emerge dev-vcs/git"
+ einfo "with bash-completion USE flag."
+ echo
+}
diff --git a/dev-vcs/git-sh/metadata.xml b/dev-vcs/git-sh/metadata.xml
new file mode 100644
index 000000000000..cca713b1b431
--- /dev/null
+++ b/dev-vcs/git-sh/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="github">rtomayko/git-sh</remote-id>
+ </upstream>
+</pkgmetadata>