summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-11-30 15:00:31 +0100
committerMarek Szuba <marecki@gentoo.org>2020-11-30 15:19:43 +0100
commitd5875e69cd8467a4b977de1ac726c2debe719583 (patch)
tree073ebe82d7a1d24b56b0749d6c58e0f8240d0038 /games-emulation
parentapp-eselect/eselect-repository: ~x64-macos keyworded (diff)
downloadgentoo-d5875e69cd8467a4b977de1ac726c2debe719583.tar.gz
gentoo-d5875e69cd8467a4b977de1ac726c2debe719583.tar.bz2
gentoo-d5875e69cd8467a4b977de1ac726c2debe719583.zip
games-emulation/fceux: migrate to lua-single.eclass
Simple enough, upstream SConstruct explicitly looks for lua5.1 headers and libraries before trying their unversioned equivalents. Closes: https://bugs.gentoo.org/752684 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fceux/fceux-2.2.3-r100.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/games-emulation/fceux/fceux-2.2.3-r100.ebuild b/games-emulation/fceux/fceux-2.2.3-r100.ebuild
new file mode 100644
index 000000000000..734feb3edc83
--- /dev/null
+++ b/games-emulation/fceux/fceux-2.2.3-r100.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-1 )
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit python-any-r1 desktop lua-single scons-utils toolchain-funcs
+
+DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
+HOMEPAGE="https://fceux.com/"
+SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk logo +lua +opengl"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+RDEPEND="
+ lua? ( ${LUA_DEPS} )
+ media-libs/libsdl[opengl?,video]
+ logo? ( media-libs/gd[png] )
+ opengl? ( virtual/opengl )
+ gtk? ( x11-libs/gtk+:3 )
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.2-warnings.patch
+ "${FILESDIR}/${P}-python3.patch"
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ tc-export CC CXX
+}
+
+src_compile() {
+ escons \
+ GTK=0 \
+ CREATE_AVI=1 \
+ SYSTEM_LUA=1 \
+ SYSTEM_MINIZIP=1 \
+ GTK3=$(usex gtk 1 0) \
+ LOGO=$(usex logo 1 0) \
+ OPENGL=$(usex opengl 1 0) \
+ LUA=$(usex lua 1 0)
+}
+
+src_install() {
+ dobin bin/fceux
+
+ doman documentation/fceux.6
+ docompress -x /usr/share/doc/${PF}/documentation /usr/share/doc/${PF}/fceux.chm
+ dodoc -r Authors changelog.txt TODO-SDL bin/fceux.chm documentation
+ rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
+ make_desktop_entry fceux FCEUX
+ doicon fceux.png
+}