summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2023-12-28 03:33:56 -0500
committerJoonas Niilola <juippis@gentoo.org>2024-02-15 15:29:46 +0200
commita56eb8f091ca17e81846c359231307f04ee41400 (patch)
tree01af37c2bd57bdad6ef8f33aebe853b82d2ad9c0 /gnome-extra
parentgnome-extra/cinnamon-translations: drop 5.6.1 (diff)
downloadgentoo-a56eb8f091ca17e81846c359231307f04ee41400.tar.gz
gentoo-a56eb8f091ca17e81846c359231307f04ee41400.tar.bz2
gentoo-a56eb8f091ca17e81846c359231307f04ee41400.zip
gnome-extra/cjs: add 6.0.0
Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cjs/Manifest1
-rw-r--r--gnome-extra/cjs/cjs-6.0.0.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
index 2d97a26bf010..7fa8119de3aa 100644
--- a/gnome-extra/cjs/Manifest
+++ b/gnome-extra/cjs/Manifest
@@ -1 +1,2 @@
DIST cjs-5.8.0.tar.gz 877668 BLAKE2B e4c031631030c2a4221937d5ca04034163f70f21e6e5ff2d0ca15f31a7455e83ecb1f977c4c4fb9a57e58d266856f817446e53b86ee87460bedf5339e33461b6 SHA512 f43bda5810b90ceab24d096d884c65503b2d9b94f5c0a9e6082215a427df97fbec4a21ee3f2d4f22d98ac24a04af1dcd9064600ec191ccec96ae0869cc803a02
+DIST cjs-6.0.0.tar.gz 877404 BLAKE2B 4290f0801f715aab1387da2ce0724376912db8ff3ad16fa8ad7eff03538dfc53ecbff2b7df0e70e52d16295b23ce51024da735d0e618b995fd3d3dfe297f9e26 SHA512 4cb359bf817d22a727683fd451ad6bde19aff4409e9033a97ef9cb204b3bd4c5e86421d7c01a267c3b4d42feb9b3bc5effb6fd970b3baf733242868c09536d95
diff --git a/gnome-extra/cjs/cjs-6.0.0.ebuild b/gnome-extra/cjs/cjs-6.0.0.ebuild
new file mode 100644
index 000000000000..ea5027ca2add
--- /dev/null
+++ b/gnome-extra/cjs/cjs-6.0.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit flag-o-matic meson pax-utils python-any-r1 virtualx
+
+DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
+SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD CC0-1.0 MIT MPL-2.0 || ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+IUSE="+cairo examples readline sysprof test"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-lang/spidermonkey:102
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gobject-introspection-1.71.0:=
+ >=dev-libs/libffi-3.3:0=
+
+ cairo? (
+ x11-libs/cairo[glib,svg(+),X]
+ x11-libs/libX11
+ )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ x11-libs/gtk+:3[introspection]
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ python_fix_shebang build
+}
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc "${S}"/examples/*
+ fi
+
+ # Required for cjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/cjs-console"
+}