summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-10-27 22:44:33 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-11-11 20:12:59 +0200
commitaed5ac29161fa961b810020224353567307639d4 (patch)
tree41c2b42d5c5a7ab33de5782dfa1f1591f59581b2 /gui-libs
parentdev-util/conan: add 1.53.0 (diff)
downloadgentoo-aed5ac29161fa961b810020224353567307639d4.tar.gz
gentoo-aed5ac29161fa961b810020224353567307639d4.tar.bz2
gentoo-aed5ac29161fa961b810020224353567307639d4.zip
gui-libs/gtk-layer-shell: add 0.8.0
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/27996 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/gtk-layer-shell/Manifest1
-rw-r--r--gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gui-libs/gtk-layer-shell/Manifest b/gui-libs/gtk-layer-shell/Manifest
index 33e5fccf3215..9b412de01454 100644
--- a/gui-libs/gtk-layer-shell/Manifest
+++ b/gui-libs/gtk-layer-shell/Manifest
@@ -1,2 +1,3 @@
DIST gtk-layer-shell-0.1.0.tar.xz 34580 BLAKE2B db815d711e53485e00de2e0b7d238f6c66ddac9ca790d5f31c44eed965ad01ee07392d27552ae21bb1eab4905cc1d5f7dad9c10fd059afb43ba85c7ea1af2aa5 SHA512 3788559405a495d43279b20b9d64e1fb0fb9be4125eb3011a623565938246310c2e81cb6d52db111e42a9cd0739bb273ccf7fcb7c52db8b74a1e44108e061c6d
DIST gtk-layer-shell-0.7.0.tar.gz 133511 BLAKE2B 49925796112f7ace01050beb56ebe2ff8a716db56075166c61a7b9d1e4f1b7402c970e14de59404ae9b05f70130542fff7601fee10e0d8780bffa34da0515aa9 SHA512 97463b4bd90318e95576e3f4b05c0acae401b8103b389cb9a0dc7716871d8d8285595ddda76419883c98c6f00fcd4ffdfd9dba48385cb8a6edcbdc7f202e2818
+DIST gtk-layer-shell-0.8.0.tar.gz 134857 BLAKE2B 2f41411c849182f95c068040a17e961a34d1a3df0bb1280b6c57046729396108d4627b5cf9bd826f17ffb5cf77f6761212af159d4326b2d34d9663063667f9f4 SHA512 710019b05785abc3cc8bc639a110f141dd2f37ce1d78e03ed361f1c21caee6c43817499fa05c8228f233bff3ac0b6f6123fa9014a87ae99edb6b10e4ff8f3dde
diff --git a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.0.ebuild b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.0.ebuild
new file mode 100644
index 000000000000..97c8b95bf9be
--- /dev/null
+++ b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+VALA_USE_DEPEND="vapigen"
+inherit vala meson python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wmww/${PN}"
+else
+ SRC_URI="https://github.com/wmww/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Library to create desktop components for Wayland using the Layer Shell protocol"
+HOMEPAGE="https://github.com/wmww/gtk-layer-shell"
+
+LICENSE="MIT-with-advertising LGPL-3+"
+SLOT="0"
+IUSE="examples gtk-doc introspection test vala"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=x11-libs/gtk+-3.24.26:3[introspection?,wayland]
+ >=dev-libs/wayland-1.10.0
+ >=dev-libs/wayland-protocols-1.16
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+ test? ( ${PYTHON_DEPS} )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use gtk-doc docs)
+ $(meson_use test tests)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}