summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-13 20:21:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-13 20:59:02 +0100
commited12a9ae116394c7275b4ea93cda4dc83ea04a8d (patch)
treed25e59c2ad46c6bdfe877274e7f3e579b9fd1573 /kde-frameworks/kwallet
parentkde-frameworks/ktextwidgets: 5.88.0 version bump (diff)
downloadgentoo-ed12a9ae116394c7275b4ea93cda4dc83ea04a8d.tar.gz
gentoo-ed12a9ae116394c7275b4ea93cda4dc83ea04a8d.tar.bz2
gentoo-ed12a9ae116394c7275b4ea93cda4dc83ea04a8d.zip
kde-frameworks/kwallet: 5.88.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.88.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index 55efd286eb82..aaa617a523d7 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.85.0.tar.xz 302844 BLAKE2B f43bd9a0046cd18490961fa0d97e40c3fe0502306afc76416f045d7fb7f74c3a54cee90b2a0fcce1f847ce97e18c3b2b680c235bb899720643e2b22b9f968c0f SHA512 7cead5cac3856ad08a71778e44ba57cecdc97cbd2abe3ec33d461edd95a8fce742ec011b8773841cc5f24d8eb282a197d462e979829c62d477c87625c5107c10
DIST kwallet-5.87.0.tar.xz 303168 BLAKE2B e67cc536ebaea1229efe4b47dc906c2b259605d43812fd185325aa437fa016318806cbce0243c9f94722aa049aac86ab22591e91bd617258064b7264224571a8 SHA512 1a62d248bc41d6a2eecaf4dddc92f49a44864e85f730a705b0c1ad973267e83191dd89a10c5374c32944177d30eed1d562927c6ac04aa1d91600abf02ec3653b
+DIST kwallet-5.88.0.tar.xz 303216 BLAKE2B 8adbfd59dd1548fe4b603a1f9f05b02a0b5dc732e3773ef1659f27b37e79a23a1d6621080160481709408ce43ec7670167def2ef0db646373070fc09f2f127b9 SHA512 ad12f9d9162181962006b6f51fde52344de15e384bb69e9c48fc376625175a3a3aafd9093f3cdaa5d99735c9fc88954c16353b14c0d4499e488008307918b847
diff --git a/kde-frameworks/kwallet/kwallet-5.88.0.ebuild b/kde-frameworks/kwallet/kwallet-5.88.0.ebuild
new file mode 100644
index 000000000000..f985d0d7667a
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.88.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gpg +man"
+
+BDEPEND="
+ man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )
+"
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after account login" kde-plasma/kwallet-pam
+ optfeature "KWallet management" kde-apps/kwalletmanager:5
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}