summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/fblogo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/fblogo')
-rw-r--r--media-gfx/fblogo/Manifest1
-rw-r--r--media-gfx/fblogo/fblogo-0.5.2.ebuild40
-rw-r--r--media-gfx/fblogo/files/fblogo-0.5.2-cross.patch36
-rw-r--r--media-gfx/fblogo/metadata.xml7
4 files changed, 84 insertions, 0 deletions
diff --git a/media-gfx/fblogo/Manifest b/media-gfx/fblogo/Manifest
new file mode 100644
index 000000000000..58348ebc7762
--- /dev/null
+++ b/media-gfx/fblogo/Manifest
@@ -0,0 +1 @@
+DIST fblogo-0.5.2.tar.gz 21874 SHA256 409d3aaaaddd6a8d22a661c68cad3283c969ed33fabe357df60fb37ab8bfae1e
diff --git a/media-gfx/fblogo/fblogo-0.5.2.ebuild b/media-gfx/fblogo/fblogo-0.5.2.ebuild
new file mode 100644
index 000000000000..619c5ecf461f
--- /dev/null
+++ b/media-gfx/fblogo/fblogo-0.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Creates images to substitute Linux boot logo"
+#HOMEPAGE="http://freakzone.net/gordon/#fblogo"
+HOMEPAGE="http://www.gentoo.org/"
+#SRC_URI="http://freakzone.net/gordon/src/${P}.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 arm ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/fblogo-0.5.2-cross.patch
+
+ sed -i -e '/-o fblogo/d' \
+ -e 's:LIBS:LDLIBS:' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README CHANGES
+}
diff --git a/media-gfx/fblogo/files/fblogo-0.5.2-cross.patch b/media-gfx/fblogo/files/fblogo-0.5.2-cross.patch
new file mode 100644
index 000000000000..dfcb2871a347
--- /dev/null
+++ b/media-gfx/fblogo/files/fblogo-0.5.2-cross.patch
@@ -0,0 +1,36 @@
+--- Makefile 2003-09-28 10:33:24.000000000 +0000
++++ Makefile 2008-05-18 19:05:12.000000000 +0000
+@@ -1,24 +1,28 @@
+-CC = gcc
++CC ?= gcc
+ LIBS = -lpng -lz -lm
+-CFLAGS = -g -O2 -W -Wall -DPNG_SETJMP_NOT_SUPPORTED
+-
++CFLAGS ?= -g -O2 -W -Wall
++CFLAGS += -DPNG_SETJMP_NOT_SUPPORTED
++LDFLAGS =
+ INSTALL = /usr/bin/install
+ INSTALL_FILE = $(INSTALL) -p -o root -g root -m 644
+ INSTALL_PROGRAM = $(INSTALL) -p -o root -g root -m 755
+ INSTALL_SCRIPT = $(INSTALL) -p -o root -g root -m 755
+
+ DESTDIR =
+-PREFIX = /usr/local
++PREFIX = /usr
+ BINDIR = ${PREFIX}/bin
+ MANDIR = ${PREFIX}/share/man
+
+ fblogo: fblogo.c
+- $(CC) -o fblogo $(CFLAGS) $(INCLUDES) $(LIBS) fblogo.c
++ $(CC) -o fblogo $(CFLAGS) $(INCLUDES) $(LDFLAGS) $(LIBS) fblogo.c
+
+ clean::
+ -rm -f *.o fblogo
+
+ install:
++ mkdir -p ${DESTDIR}${PREFIX}
++ mkdir -p ${DESTDIR}${BINDIR}
++ mkdir -p ${DESTDIR}${MANDIR}/man1
+ ${INSTALL_PROGRAM} fblogo ${DESTDIR}${BINDIR}
+ ${INSTALL_SCRIPT} fblogo_patch ${DESTDIR}${BINDIR}
+ ${INSTALL_FILE} fblogo.1 ${DESTDIR}${MANDIR}/man1
diff --git a/media-gfx/fblogo/metadata.xml b/media-gfx/fblogo/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/media-gfx/fblogo/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>